External Article

How to Attach a SQL Server Database without a Transaction Log and with Open Transactions

You want to attach a SQL Server database that does not have the transaction log files and get the following error: "The log cannot be rebuilt because there were open transactions/users when the database was shutdown, no checkpoint occurred to the database, or the database was read-only. This error could occur if the transaction log file was manually deleted or lost due to a hardware or environment failure." In this tip I will help you to successfully attach the transaction log to the problematic SQL Server database.

External Article

Technology Makes a Difference

As the world deals with the Covid-19 pandemic, technology is making some things better for those of us in isolation. We are also better equipped today to fight the disease. Researchers are using artificial intelligence to quickly develop vaccines and treatments.

Blogs

Car Update September 2026

By

Software is hard. While I love our Lucid Gravity, I realize that they are...

Microsoft Tools for Making Data AI-Ready

By

Making Data AI-Ready, Part 2 (This is the second article in a three-part series...

Local Models Using GPUs with Ollama

By

Can you use your GPUs when running a local model under Ollama? You can,...

Read the latest Blogs

Forums

Moving Beyond the Reboot: Finding the Culprit Behind Memory Pressure

By Pablo Echeverria

Comments posted to this topic are about the item Moving Beyond the Reboot: Finding...

Reserved Words I

By Steve Jones - SSC Editor

Comments posted to this topic are about the item Reserved Words I

Get Along

By Steve Jones - SSC Editor

Comments posted to this topic are about the item Get Along

Visit the forum

Question of the Day

Reserved Words I

Which of these are not reserved words?

See possible answers