SQL State Error 'HYT00'

  • kreskins

    Default port

    Points: 1429

    My web server is not allowing me to create a system DSN to connect to another server. I am using TCP/IP net lib, I have tried upgrading MDAC, I still am unable to get past the screen where it asks for authentication method. It throws the the following error:

    Connection Failed:

    SQLState: 'HYT00'

    SQL Server Error: 0

    [Microsoft][ODBC SQL Server Driver]Timeout expired.

    I don't know if this is an issue but the servers have gateways that are on different subnets. one is on a 1.2.x subnet and the other is on a 1.2.y subnet. Would this contribute to my problems

    thanks for any help

    Thanks For your continued Help.


    Thanks For your continued Help.

  • Leon Platt

    SSCommitted

    Points: 1921

    In odbc config where it ask What sql server do you want to connect to? was your srever listed in the dropdown or did you type it in?

    Can you ping the tcp/ip address of the sql server from your web server?

  • kreskins

    Default port

    Points: 1429

    The server was originally not in the list. I can ping the server from a command line using IP address

    Thanks For your continued Help.


    Thanks For your continued Help.

  • psieloff

    Valued Member

    Points: 55

    In your DSN, try using the ip address of the server instead of the server name.

  • kreskins

    Default port

    Points: 1429

    I tried that a week or so ago and it worked. Thanks for the follow-up anyway. Have a great day.

    Kevin

    Thanks For your continued Help.


    Thanks For your continued Help.

  • Antares686

    SSC Guru

    Points: 125444

    What type of connection are you setting up. NT Auth or SQL Auth?

  • DanG

    SSC Eights!

    Points: 811

    Hello,

    I have just stumbled upon this same problem myself (same exact error). My application which uses these DSN's I have created some time ago, do work, because I have the connection timeout set with no limit. However if I go into the control panel and try to test them I get this error. This poses a problem for me because I can't add any new DSN's for the server.

    Just seems like SQL is taking a looong time to respond.

    Any other ideas to trouble-shoot this problem?

    Thanks,

    Dan

    Edited by - DanG on 03/02/2002 07:03:27 AM

  • Antares686

    SSC Guru

    Points: 125444

    So you get this on your DSN connection. Try from the machine you are having troubles with and pining the SQL Server. Also are you using named connections or ip connections?

    "Don't roll your eyes at me. I will tape them in place." (Teacher on Boston Public)

  • DanG

    SSC Eights!

    Points: 811

    Hello,

    I can ping SQL from the client - no problems. I am using IP connections.

    BTW: All my clients are having this same issue with SQL and DSN error.

    Thanks,

    Dan

  • DanG

    SSC Eights!

    Points: 811

    Hello again,

    I even went so far as to reinstall SQL this morning, and still have the same issue.

    Dan

  • Andy Warren

    SSC Guru

    Points: 119675

    Hey Dan,

    You can ping the IP address from the client, correct? Have you tried connecting via Query Analyzer on the client? DSN's use ODBC, QA does also. There's no magic to a DSN, it's really just a way to keep your connect string external to the app. Also as far as connecting there is really no difference between system, user, and file DSN's. Are you using SQL or NT authentication? Have you run Profiler while you're testing to see what if anything is coming across? What kind of lag are you seeing when you ping/tracert? I would suspect a network issue more than a SQL issue. Only other thought is to install latest MDAC on one client and test.

    Andy

  • Antares686

    SSC Guru

    Points: 125444

    When you get to the autchenication screen there is a button for client config. Did you check in there to make sure that it is deffiently using the TCP/IP network library and also make sure it does not dynamcially determine the port, uncheck that option and put the correct port in. To me it looks like the server has answered as it is there but does not answer the authorization fast enough before the timeout occurrs. I don't believe this is MDAC related or server side configuration but I am still trying to directly reporduce. You may if your company owns one wanrt to put a packet sniffer of the connection from the user or the local router to the SQL server to see if you are suffering a packet problem. Also run Performance monitor at the client and the server to see if you have a high number of packets being lost this could explain why the client sees the server but is having troubles talking to it.

    "Don't roll your eyes at me. I will tape them in place." (Teacher on Boston Public)

  • DanG

    SSC Eights!

    Points: 811

    Hello guys,

    Yes I can ping the SQL machine from the clients and the response is good. When I tried using QA from the client, I got the following:

    Unable to connect to server P4

    ODBC: Msg 0, Level 16, State1

    .... Timeout Expired

    I just made sure it is using TCP and unchecked determine dynamically, so it is using 1433.

    I still have the same error.

    When I test a DSN on the machine with SQL, it is successful and the response is immediate.

    Appreciate the help,

    Dan

  • DanG

    SSC Eights!

    Points: 811

    Ok, here is something strange...

    I decided to enable MultiProtocol on the server. Once I did that, I came back to the Client and set the DSN to MultiProtocol. Click Next and after waiting a bit - Error. I then went back into the configuration and set the DSN back to TCP. Click Next and it moved on and the test was successful and quick.

    Does this give any clues as to the problem...

    Dan

  • Antares686

    SSC Guru

    Points: 125444

    No not really, could have been a corruption in the configuration that reset when you moved off TCP/IP then back on, but I would have to dig in the registry and try to force it myself. If I get a chance I have a test machine to play like this and will.

    "Don't roll your eyes at me. I will tape them in place." (Teacher on Boston Public)

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic. Login to reply