Nonrecoverable I/O error occured attempt db backup

  • I am running 2000 Adv Server with SQL Server 2000. Recently I have been getting the following: Nonrecoverable I/O error occured on file D:\MSSQL...MDF, Backup database is terminating abnormally. If I reboot the machine it will backup successfully. Machine up less than 48hrs. 8GB memory w/ 3GB, PAE switches w/ AWE enabled. Does this sound like a Tempdb problem, page file issue or other? Please advise if experience w/ this problem.


  • Can you post exact error message? Which database (user, system or tempdb) are you referring to? Have you performed hardware check in I/O disk storage?

    Edited by - allen_cui on 11/04/2003 09:01:13 AM

  • Nonrecoverable I/O error occured on file 'D:\MSSQL\Data\FS8CNV.mdf', BACKUP DATABASE is terminating abnormally. This is a conversion database that is constantly refreshed. This is a PeopleSoft database. PeopleSoft is infamous for heavily using Tempdb. I have not performed a hardware check recently. I will give that a shot during non peak hours.

  • You received this erro when backing up user database that backup is nothing to do with TEMPDB. You also need review machine application/system logs that may give you some error hints.

  • Sounds like bad stripes on the drives. This is very bad as your database may become suspect or corrupt! Run a Chkdsk /F /R , make sure SQL is shut down when running the chkdsk. I was getting the same errors on my server and ended up replacing the drives and controller...

  • This error is occuring on 3 separate development boxes. I find it hard to believe that each one has bad drives and controllers. Possible, not probable.

  • Have you run DBCC CHECKDB to your database?

  • how you do your backup - on backup devices?

    - what type of backup?

    try and run DBCC CHECKFILE(file_name)

  • I ran CHECKDB on all three databases. 0 errors. Ran backup to local disk immediately after and received same error. Backup to device fails as well. DB or log backups both fail.

  • Do you see any backup related error messages in SQL Server errorlog, for example, "Insufficient system resources exist to complete the requested service."? How large is your database? Which Windows version and service pack you are running?

  • Yes. Windows sp2, SQL Server sp3

    BACKUP failed to complete the command BACKUP LOG [FS8DEV] TO [FS8DEVlog] WITH NOINIT , NOUNLOAD , NAME = N'FS8DEV Log Backup Hourly', SKIP , STATS = 10, NOFORMAT

    Internal I/O request 0x347CD5E8: Op: ReadLogScattered, pBuffer: 0x0C1E0000, Size: 983040, Position: 8863744, EndingOffset: 13049856, SegLen: 983040, SegStride: 983040, UMS: Internal: 0x0, InternalHigh: 0xF0000, Offset: 0x13EEBE00, OffsetHigh: 0x0, m_buf: 0x0C1E0000, m_len: 983040, m_actualBytes: 0, m_errcode: 1450, File: D:\MSSQL\MSSQL\Data\FS8DEVlog.ldf

    1450 points to page file I believe. I have been down that rabbit hole. I just rebooted the machine and can backup fine. Happening every couple of days.

  • Ok, I have seen this problem happening to backup/restore large databases in my environment. We fixed it by following Microsoft KB;en-us;304101&Product=win2000.

    I just had similar problem few days ago when tried to restore 550GB database into one server that restoration works fine for quite long time. This time, I didn't change the registry, instead, I applied Windows service pack 3 and security fix ms03-039, and restoartion started to work after that.

    Edited by - allen_cui on 11/05/2003 12:54:15 PM

  • I went through this fix on one machine a month or so back. I set the registry value to 10 on the first and did not add the second value since it stated if you are running /3GB & PAE together, do not set this setting w/o extensive testing before... I also spread out my daily backups so that they were not firing off at the same time. This seem to work for a couple of days and then back to same problem.

  • Since same problem happens to few of your servers, I would recommend you to configure the registry to one of servers to see whether same issue occurs again. Or go Windows service pack 3 and security fix ms03-039.

  • Thanks. I am considering Win2k sp4 now and have already applied ms03-039

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic. Login to reply