Forum Replies Created

Viewing 15 posts - 18,001 through 18,015 (of 49,552 total)

  • RE: Transaction Log Full error 9002.

    Please read through this: http://www.sqlservercentral.com/articles/Transaction+Log/72488/

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Stored Procedure Errors - Read Log via T-SQL?

    Extended events (seeing as you're on SQL 2008) would probably be the optimal if you just want to record the errors that have happened. But if you want error handling,...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Stored Procedure error

    This chunk has nothing preventing that return parameter being null

    IF @VALOR is null

    BEGIN

    SET @STRSQL ='INSERT INTO '+@DB+'dbo.UTILIZADORES values (''SGSC'',

    ''Utilizador criado para ser usado pelo SGSC''

    ,3,''1Yzw12ptag341*'',''administrador'',GETDATE()))'

    EXEC (@STRSQL)

    SET @STRSQL = 'select @val...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Automate shrink log file process

    deep_kkumar (6/18/2012)


    No replication.

    No replication? But the link you posted was about the replication log wait. If the database has no replication then see the replication section of this http://www.sqlservercentral.com/articles/Transaction+Log/72488/

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Automate shrink log file process

    Well, the obvious possibility that comes to mind is that the log reader agent is falling badly behind because of internal log fragmentation, which will be worsened by shrinking the...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Automate shrink log file process

    deep_kkumar (6/18/2012)


    We had an issue with one of the log files grow out of proportion.

    In that case, please read through this: http://www.sqlservercentral.com/articles/Transaction+Log/72488/

    By repeatedly shrinking, you're addressing symptoms, not causes...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Automate shrink log file process

    Scheduled shrinking of logs is a terrible practice. Why do you want to do this to your databases?

    Please read through this - Managing Transaction Logs[/url]

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: I need know how many users exists for licensing in sql 2005

    As many as you have users using the SQL instance.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Disk defragmentation - can this corrupt SQL data?

    It's fine, but SQL Server must be stopped for the duration.

    If you consider using one of the so-called online defrag tools, make sure it's supported with SQL Server or it...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: XML Column in Index include

    If you include the XML column, you are duplicating the column. The XML data will be stored twice, once in the table, once in the index. If that's a couple...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Stored Procedure Errors - Read Log via T-SQL?

    Rob-350472 (6/18/2012)


    Guys,

    If an SP causes an error - e.g. you've written an SP that uses a table that doesn't exist, is this logged somewhere in SQL, and if so, can...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: AD Groups vs Windows Login Priority

    Deny always overrides grant. Only exception is a sysadmin, to which nothing can be denied.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Server side tracing - where is the data stored?

    It goes into the file. The explorer properties may not be up to date until the trace is stopped. TempDB is not involved at all.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Stored Procedure error

    okbangas (6/18/2012)


    Btw, I do hope you did not actually post an adminstrator password?

    Not to mention storing passwords in plain text...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Delete Trigger

    eklavu (6/18/2012)


    I think I would need to pass the username and use the output clause. Would you think that make sense?. I'll try it now 🙂

    Doesn't work that way. Only...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass

Viewing 15 posts - 18,001 through 18,015 (of 49,552 total)