URGENT !! : SQLServerAgent could not be started

  • the following error appears when i try to start the sql server agent:

    SQLServerAgent could not be started (reason: Unable to connect to server; SQLServerAgent cannot start).

    i have tried the solution at http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q237604 to add BUILTIN\Administrators account back into SQL Server this does not work, is there something i am missing ?

    Running on windows 2000 SS7 sp2

    this is very urgent



  • How are SQL Server Agent and MSSQl Server configure in the services? Which account?

    Can you log in as the account under which SSA is running?

    Steve Jones


  • The SQL SERVER service is running under the same account with no problems and the account can be logged in under.

    this SSA service was runing fine and when i checked the event log to c when this problem started i seen the following error 'the data portion of event 19002 from mssql sql server is invalid' and when i checked event 19002 it said 'set service failed(reason) the handle is invalid' i've tried using a diffferent account etc but to no avail....

    Will applying the service pack again do any good ?

  • the services are setup to startup automatically and i have the sql server agent set to retry twice to start on a failed start.

    Could the problem be a corrupt dll or exe ?

  • It could be, but would be pretty rare - I've never seen it. What changed before it stopped working? Disk permissions? Account names? Install some new software, service pack, etc? You might also want to reboot the server.


  • as far as i can see the only thing that happened was a reboot...

    there was nothing else done, i have gone thru the sql error log and event log...

    the password the sql account uses was changed a few days after this happened .

    is it good practice to stop the sql service manually b4 a reboot ?

    the server has been rebooted a few times to try to sort this problem out but to no avail.

    I have been on to Compaq support and the suggested most things that i had tried already, the only extra thing they suggested was to install mdac 2.5 + sp2 and reapply the sql server service pack.

  • Not necessary as long as its a standard reboot, not a pull the plug out of the wall reboot.

    Keep in mind there could have been another change made prior to the reboot that had not taken affect. I still think its an account/password issue. Why not just set up a new account and new password, try it again?


  • i tried setting up another account ....same thing... is there any way around this, can the sql agent be installed again ?

  • Can you try in under the local administrator account? I am concerned that permissions or security were altered somewhere else. Itis possible there is some corruption somewhere in a file and applying the service pack might fix it. I'd download the service pack again, thought, rather than using the same version. Also, V7 has SP3 out.

    Steve Jones


  • Will do...

    the other fix that was applied to this installation was the following :

    Please see the below fix which was previously sucessfully applied to SQL 7.0

    on NT 4.0:

    SQLServer Agent hangs on starting:


    When you start the server, Event Viewer records Event ID 7022,

    SQLServerAgent service hung on starting"


    To make sure the necessary services are present in the registry,

    follow these steps:

    1. Start Registry Editor (Regedt32 - not regedit)

    2. Navigate to the following registry location


    3. In the right hand pane of the Registry Editor window, double-click

    on the value DependOnService

    4. In the Multi-String Editor dialog box, add the service "NetBios"

    on a seperate line and click OK.

    5. Quit Registry Editor and restart the computer

    The server is win2k could this be a related problem ?

    but the service was running ok after this fix was applied ...

  • It's possible this applies, but many things from v4.0 do not apply in w2k. Also, I would think that NetBIOs would be running.

    I'd look at reapplying the sp. Your error is something I've not seen, and it looks like none of the guys here have seen it either. You may need to invest the $250 in calling MS.

    Steve Jones


  • I would upgrade to SP3, but before doing so check in the control panel services and check what user you are using and that it has domain administrator rights and retype in the password. Check that it is the same user in the sql Agent properties.Retype the password.

  • Thanks guys, for all your help

  • As an update to this topic, I think the security on WIN2K was set too tight and will try to verify this by doing an install of ss7 on an image of this server b4 any measures to tighten win2k security were applied !!!.

  • ok, finally an answer to this.

    Go to Local security policy / Account policies / password policy / Passwords must meet complexity requirements was enabled .

    set this to disabled.

    plus in the network config utilty in the named pipes \\servername\pipe\sql\query was changed to \\.\pipe\sql\query

    these changes seemed to have fixed the problem.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic. Login to reply