Stupid Question: Return Object Explorer to It's original position

  • Like2SQL

    SSCommitted

    Points: 1662

    Stupid question but I accidentally moved object explorer from it's original default position on SSMS. By default, object explorer is to the left, and query window is to the right. Now object explorer seems to have been "undocked" and query window occupies the screen from left to right, such that if I open a new query it opens "behind" object explorer. How do I restore the original "default" view in SSMS?

  • mister.magoo

    SSC-Forever

    Points: 47068

    Not a stupid question at all!

    Just grab the Object Explorer windows and drag it until a blue cross appears. Continue dragging the window and point your mouse at the different points of the cross. This will display a greenish highlight within SSMS to show where the window will dock. When you have the one you want, let go of the mouse button.

    The blue cross looks like the one in the image below...although that is not the object explorer window being docked (it's just a picture I found by Googling)

    MM



    select geometry::STGeomFromWKB(0x0106000000020000000103000000010000000B0000001000000000000840000000000000003DD8CCCCCCCCCC0840000000000000003DD8CCCCCCCCCC08408014AE47E17AFC3F040000000000104000CDCCCCCCCCEC3F9C999999999913408014AE47E17AFC3F9C99999999991340000000000000003D0000000000001440000000000000003D000000000000144000000000000000400400000000001040000000000000F03F100000000000084000000000000000401000000000000840000000000000003D0103000000010000000B000000000000000000143D000000000000003D009E99999999B93F000000000000003D009E99999999B93F8014AE47E17AFC3F400000000000F03F00CDCCCCCCCCEC3FA06666666666FE3F8014AE47E17AFC3FA06666666666FE3F000000000000003D1800000000000040000000000000003D18000000000000400000000000000040400000000000F03F000000000000F03F000000000000143D0000000000000040000000000000143D000000000000003D, 0);

  • Forum Etiquette: How to post Reporting Services problems
  • [/url]
  • Forum Etiquette: How to post data/code on a forum to get the best help - by Jeff Moden
  • [/url]
  • How to Post Performance Problems - by Gail Shaw
  • [/url]

  • aykefam

    Old Hand

    Points: 367

    Just open SQL server management studio. On the menu bar, select Window, then Reset Window Layout. This will place object explorer to its original position. But bear in mind that, this will reset all your settings to the default if you have any!!!

  • LCampbell731

    SSC Enthusiast

    Points: 131

    Holy COW! This happened to me by accident and I had no clue I had "done" anything. Thanks for answering. I'm back in familiar territory.

  • kapil_kk

    SSC-Insane

    Points: 21316

    You can't say this as a stupid qurstion, may be there are many other users who faced this type of problem and didn't find a solution for this.....

    Main thing is to have gutts to post it wether it may be a stupid question for others or not...... Keep posting question 😉

    For solution you can just dragged the window on the lift side of the window until a blue border appears on the screen.... It will works 😉

    _______________________________________________________________
    To get quick answer follow this link:
    http://www.sqlservercentral.com/articles/Best+Practices/61537/

  • aravindkumar.h23

    SSC Enthusiast

    Points: 192

    @@ aykefam :

    Thanks for your reply. That was so easy and it fixed my two days frustration ,handling this undocked object explorer 😀

  • sqldkc

    SSC Enthusiast

    Points: 147

    Hi All,

    1) Right Click on object explorer

    2) Now you can see an option called "Dock"

    3) Select "Dock"

    By this object explorer comes to normal position as earlier. Thank You.:hehe:

    Regards,

    Kalyan

  • glennc 78606

    SSC Journeyman

    Points: 95

    If you're like me, you're looking for the object explorer tree on the left.

    When you double click a query, this doesn't open by default.

    Click

    File-->Connect Object Explorer

    You'll have to authenticate. The next time you open it, the object explorer may be open but it won't show the details. You'll have to click "connect" and authenticate.

  • amansoach

    SSC Enthusiast

    Points: 121

    It helped me!

  • soudasv

    SSC Enthusiast

    Points: 106

    Thank you VM for saving my sanity. I was about to give after juggling for 2 days.

  • Bhushan Kulkarni

    SSCrazy

    Points: 2829

    Ha ha, it happened with me also many times..:cool:

  • WarrenDar2

    SSC Veteran

    Points: 266

    that works. Thanks.

  • toybum2001

    SSC Journeyman

    Points: 95

    There is truth in what you said. I had the same problem just now and couldn't figure it out. I had to turn to Google for solution. The solution posted here did work for me. Thanks to the problem solvers.:-)

  • Richard Parfitt

    SSC Journeyman

    Points: 83

    Hey, thanks a lot for this - definitely not a stupid question as it just saved me when my undocked windows had their title bars off the top of the screen after I changed from home working to the office and all the screen sizes are different - the Window -> Reset Window Layout is perfect so I can start again.

  • peacemaker

    SSC Enthusiast

    Points: 186

    This is not a stupid question. I faced it and until we know how this works it is annoying.

  • Viewing 15 posts - 1 through 15 (of 24 total)

    You must be logged in to reply to this topic. Login to reply