SSMS Ctrl+U Shortcut

  • Adam McArdle

    Mr or Mrs. 500

    Points: 540

    For as long as I can remember, Ctrl+U takes you to the list of databases on the server, allowing you to easily switch between them. However I've just had to reinstall Management Studio and now it's not working. I'm tearing my hair out trying to find how you change the setting, to no avail. 

    Has this happened to anyone else, does anyone know how to fix it?!

    Thanks

  • Luis Cazares

    SSC Guru

    Points: 183638

    Adam McArdle - Monday, March 18, 2019 8:23 AM

    For as long as I can remember, Ctrl+U takes you to the list of databases on the server, allowing you to easily switch between them. However I've just had to reinstall Management Studio and now it's not working. I'm tearing my hair out trying to find how you change the setting, to no avail. 

    Has this happened to anyone else, does anyone know how to fix it?!

    Thanks

    Could that have been a personalized shortcut? There's no reference for that shortcut having that functionality
    SQL Server Management Studio Keyboard Shortcuts

    Luis C.
    General Disclaimer:
    Are you seriously taking the advice and code from someone from the internet without testing it? Do you at least understand it? Or can it easily kill your server?

    How to post data/code on a forum to get the best help: Option 1 / Option 2
  • tripleAxe

    SSCertifiable

    Points: 5605

    I'm using SSMS v 17.9.1 and have that functionality.  From the Query editor window when I enter Ctrl+U focus jumps to the dropdown list of  Available Databases.  If I hover the mouse over this dropdown I get the tool tip to appear with the text "Available Databases (Ctrl + U).

    I am using the SQL Server 2008 R2 keyboard scheme rather than the SQL Server 2017 scheme (keyboard shortcuts based on Microsoft Visual Studio 2010).

  • Y.B.

    SSChampion

    Points: 11549

    Well, you are definitely not crazy.

    EDIT: I also have Redgate's SQL Prompt installed so I thought it might be a custom shortcut as Luis suggested but I couldn't not find that documented either.

    Try: CTRL+ALT+J this apparently does the same as well (at least on my machine).  Found the only reference here...very obscure. 


    SELECT quote FROM brain WHERE original = 1
    0 rows returned

  • jonathan.crawford

    SSCertifiable

    Points: 6585

    I lost my ability to hide results last week, had to go to Tools-->Options-->General-->Keyboard and click Reset to default keyboard. fixed it right up. Maybe that's the same issue?

    -------------------------------------------------------------------------------------------------------------------------------------
    Please follow Best Practices For Posting On Forums to receive quicker and higher quality responses

  • Luis Cazares

    SSC Guru

    Points: 183638

    I had to go back and checked that I can see the tooltip but it won't work. I'm sorry that I can't help, but I'm more confused now. It could probably be reported as a bug?

    Luis C.
    General Disclaimer:
    Are you seriously taking the advice and code from someone from the internet without testing it? Do you at least understand it? Or can it easily kill your server?

    How to post data/code on a forum to get the best help: Option 1 / Option 2
  • Adam McArdle

    Mr or Mrs. 500

    Points: 540

    Well, at least I'm not going mad. Mine's apparently set to Alt-D

    But that doesn't work, and neither does CTRL-ALT-J.

    Thanks for your help everyone, at least it's confirmed that I'm not losing my mind

  • Adam McArdle

    Mr or Mrs. 500

    Points: 540

    For the benefit of exasperated developers in years to come, here's how I fixed it. Firstly, jump ahead to the step 4. I'm certain I'd done that prior to re-installing, but it might be worth doing this step first to see if it helps. Failing that, do all this:

    1. First I uninstalled SSMS, SQL Prompt and any other addons
    2. Then I deleted all of these folders:

    3. Then I re-installed SSMS

    4. Lastly, I went into options, environment, keyboard. Pick "Visual Studio 2010 Compatible" from the download and MAKE SURE YOU HIT RESET. So far as I can tell, picking the drop-down changes nothing, it's only when you hit Reset that it changes everything. 

  • speige

    Newbie

    Points: 1

    In my case uninstalling Apex SQL Refactor fixed it. Didn't research if it was due to a specific setting within Apex, so it may have been possible to keep Apex & still have CTRL+U working.

  • tmbr_wulf

    Newbie

    Points: 1

    This has been driving me nuts for months as I heavily used that shortcut and speige's comment was the lightbulb for me.  It turns out that it is an older version of Apex SQL Refactor that is blocking this shortcut.  I was running version 2018.xx.yyyy and updated to 2020.04.0423 and the shortcut is back in business!  The update option is in the ApexSQL menu item within SSMS, ApexSQL > ApexSQL Refactor > Resources > Get updates...

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic. Login to reply