SQLServer hangs the system

  • xovenca

    SSC Rookie

    Points: 25

    I have examined the memory usage of my SQL Server 7.0 and find sqlservr.exe is using most of the server memory. Therefore, the system don´t works well. The computer is a PDC (W2000 advanced server) and users can´t be validated, it´s impossible to launch any application. When I had SQLServer on NT 4.0

    all works well. Why? Are there any incompatibilities? Thanks.

  • Wesley Brown

    SSChampion

    Points: 12045

    I for one don't recommend 7.0 on 2000. You can set the memory limits on 7.0 and make sure your box has enough memory for the OS.

    http://www.sqlserverio.com
    http://www.cactuss.org
    http://www.salssa.org

  • K. Brian Kelley

    SSC Guru

    Points: 114485

    Burthold is right, you can set the memory usage for SQL Server.

    The first thing to remember is Microsoft doesn't recommend any memory intensive apps running on a DC. Period. Reason being what you're seeing right now. Validating users, communicating with BDCs, etc. all take up resources. If another app has those resources, you're going to have problems.

    When SQL Server is involved and set to dynamic memory usage, the thing to remember is that SQL Server will take up as much memory as it can as needed. The reason being is that SQL Server is going to try and minimize disk I/Os. Now, when another application needs memory, SQL Server will go through the process of letting go of that memory, but it's not exactly super fast. So what's probably happening, depending on the amount of data and the utilization of SQL Server, is that SQL Server is continually expanding the memory it uses until your DC has none left for its validation functions, etc.

    If you don't have an option of putting the DC and SQL Server on different boxes, about the only solution you've got is to limit the amount of memory that SQL Server can use.

    K. Brian Kelley

    bkelley@agfirst.com

    K. Brian Kelley
    @kbriankelley

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply