SQL Copy Database Wizard Broken

  • bucrepus

    SSC Veteran

    Points: 268

    I have been using  the SQL Copy Database Wizard (right click on the DB and Copy Database option) through the GUI (SMS)  to copy a DB up until SQL 2016. Every installation I have where 2016 or greater has been involved the feature is broken and always gives the same error. It doesn't matter if I use an existing DB I have imported or create a new blank test DB. Same error. I have seen numerous posts on this error but no solution. I have installed numerous versions of SQL Management studio (including the latest) but the GUI appears to be broken on all of them. In SQL 2014 standard this issue doesn't happen. Anyone know of a fix for this? This is becoming very frustrating. I have even tried a clean install of server & SQL. Same results. The error in the SQL log for every computer is always an INDEX error.

    OnError,TESTSVR,TESTSVR\Administrator,CDW_TESTSVR_TESTSVR_1,{3CA6823C-A220-4ABE-A900-DAB1D9485F38},{594FCC26-657E-4036-9C21-E53D74BB4C90},11/06/2019 12:16:35,11/06/2019 12:16:35,0,0x,Index was out of range. Must be non-negative and less than the size of the collection.

     

    This is happening on every machine I install SQL 2016 or 2017 with Management Studio. I have tried SQL Management Studio all the way back to 16.5.3....I have no clue what the error is referring to. The DB can be a test db with no data and I still get this error. In the wizard I am using the SQL copy objects method radio button .

    Thanks for your time..

    • This topic was modified 6 months, 3 weeks ago by  bucrepus. Reason: Update
  • Beatrix Kiddo

    SSC-Dedicated

    Points: 32407

    Could you not just do a backup and restore instead?

  • bucrepus

    SSC Veteran

    Points: 268

    No, I actually need a 'copy' that I can import / attach on another server, maybe even attaching to a newer version of SQL on another machine. I have tried B/R, works great locally, but have had issues trying to do a restore on  other servers.

    Anyway, thanks for the reply and your time. I resolved the issue. This was a bug that was fixed in SP2 and one of the cumulative updates. I only had SP1; when I patched all my installations the issue went away.

    Thanks again..

     

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply