Reports stop showing extra pages.

  • Hi,

    Very simple question. How do I stop the report from displaying a blank page each time I want to see a new record.?


    Force new paege is set to None



  • Ritesh,

    From your description it is hard to tell exactly what could be causing the blank page to print with each record on your report. The first place I would check is your page layout. Make sure that your report is not wider then the page layout settings. If it is, there could be blank data overflowing onto a second page and causing the extra page to print.


  • To amplify, you want to make sure that the width of the body of the report will fit on a single page - this would be the width of the page, minus the width of the right and left margins.

  • Thanks guys. Can't believe it was that simple . Pulling my hair out over it. Thanks once again.

    Got another Question to ask.

    I need to set up users and permissions. I used the wizard. But when I click on the database I'm alwayys logged in as admin. I want users to enter their own username and password.

    How Do I do this? Help

  • I assume that you mean setting up user/perms for the Access database.  Here are the steps:

    1) Logged in as Admin, choose Tools -> Security -> Workgroup Administrator.

    2) On the window that appears, click "Create" to create a new workgroup file.  (This allows you to preserve the orig. workgroup file that is installed with Access).  Enter the criteria to create the new workgroup file and click "OK".

    3) Once the new workgroup file has been created, choose Tools -> Security -> Workgroup Administrator and click "Join" to join to the new workgroup file you created.

    4) Logged in as Admin, create user/groups using Tools -> User/Group Accounts

    5) Use the security features under the Tools menu to secure the database.

    6) Close Access.

    7) Start up Access again, login as one of the users, use Tools -> User/Group Accounts to change the logon password for that user. (Repeat this step for each user).

    Hope this helps.




    Have a good day,

    Norene Malaney

  • Theres no such thing as Workgroup Administrator.

    I'm doing it in access

  • Ah, but which version of Access?  Here's some instructions I've used in the past, perhaps this will help.  Microsoft also includes some pretty good instructions with the product; try searching the HELP in Access, or the knowledge base on the web.

    1. Make sure you have a backup of your database!
    2. If you do this on an existing database, the objects probably have an owner of “Admin”, which means anyone logged in as “Admin” will have all authorities, regardless of other security settings.  The ownership is set to the logon that creates the objects.  The ownership needs to be changed to <yourworkgroupname>; the easiest way to do that is to build a blank database, create the security, and then link the tables and import the forms from an existing database. 
    3. Open Access 2002, and go to Tools / Security / Workgroup Administrator.  (If using Access 2000, go to the C:\ProgramFiles\Microsoft Access 2000\Office folder and find the icon for “MS Access Workgroup Administration” [which points to folder 1033\WRKGADM.EXE] and double-click it.)
    4. Create workgroup <yourworkgroupname>, and save it in a file called “systemZ.mdw” (or some such name).  Make sure you keep the  WID you use to create this workgroup (someplace safe) in case you ever need to recreate the work group.  Note the PID as well.
    5. Make sure you have “joined” this workgroup, then close the workgroup adminstrator window(s)
    6. Go to Tools / Security / User and Group Accounts
    7. Add the <yourworkgroupname> user.  Use the  PID you wrote down earlier.
    8. Close Access.
    9. Open Access  via the “run” command, with “/user <yourworkgroupname>” (no password).
    10. Open Tools / Security / User and Group Accounts.  Note that you are logged in as <yourworkgroupname>.
    11. Set the password for <yourworkgroupname> (the password to use is listed in the password file).
    12. Be really careful with this next part!
    13. Make sure <yourworkgroupname> is part of the “Admins” group. 
    14. Remove the “Admin” userid from the “Admins” group, but leave it in the “Users” group.  This will allow only the <yourworkgroupname> id to have authority over all aspects of the databases; the Admins group is the default login group, and has read authority on everything, but is not allowed to update data.


    Here there be dragons...,

    Steph Brown

Viewing 7 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic. Login to reply