Register Integration Services 'Class not registered'

  • I recently installed SQL Server 2012 Developer Edition on my laptop. I'm SYSADMIN on every SQL Server.

    in SSMS, under Integration Services, when I attempt to Register our production Integration Services Server -- I receive error msg: "Class not registered" and the Microsoft error splash box references -- "This error can occur when you try to connect to a SQL Server 2005 Integration Services service from the current version of the SQL Server tools."

    Our production SQL Server is SQL 2008 R2 Ent edition. My local SQL Server is 2012 Developer edition. Thoughts?

  • One finding.. when I started up my SQL Server 2008 R2 Developer edition SSMS, I was then able to connect to my registered Integration Services server which is also SQL Server 2008 R2.

    Within SSMS --

    is it true --- you can only connect to SQL 2012 Integration Services using SQL Server 2012 SSMS?

    is it true --- you can only connect to SQL 2008 R2 Integration Services using SQL Server 2008 R2 SSMS?

    is it true --- you can only connect to SQL 2005 Integration Services using SQL Server 2005 SSMS?

  • SSMS 2012 will only connect to SSIS 2012 out of the box. I found a site that lists a work-a-round, but I haven't tried it personally to see if it works.

  • I can't remember if SSMS 2008 R2 would let you connect to SSIS 2005 or not. If it did it could present some issues if you tried right-clicking on a package and selected "Run package". That uses your local dtexec to run the package and you could potentially run into issues running a 2005 package under the 2008 R2 dtexec. One gotcha I found out when upgrading 2008R2 packages to 2012 is with the script tasks. They don't get upgraded and the error handling completely changed in 2012. If you try running a 2008R2 package with script tasks in it under the 2012 dtexec, I would think it would just error out.

  • I have tried it and it works. SQL 2005 and 2008 R2.

  • This link worked. You'll need to change the folder's name to the server you want, and then the

    server's name below, for EACH SSIS server you want, but it's nice to have.


  • How to open this config file and where we want to create folder?

  • Most likely this is an issue with the sql server and SSMS version compatibility. I face similar problem. I am using sql server 2017 with the latest ssms version(18.4). Installing the old SSMS 17.9( fixed the issue. I dont know why Microsoft didn't fix this issue. I think the latest SSMS version should be backward compatible and should open all versions of Integration services.

Viewing 8 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply