IE Error Loading Taskpad view in EM

  • I am getting the error "An error has occurred in the script of this page" when I

    view the databases in Taskpad view in Enterprise Manager. Details of the error

    are as below:

    Dialog Box Title: Internet Explorer Script Error

    'An error has occurred in the script of this page

    Line: 305

    Char: 2

    Error: Unspecified error

    Code: 0


    res:// C:\Program%20Files\Microsoft%20SQL%20Server\80\Too


    33\sqlmmc.rll/Tabs.html Do you want to continue running scripts on this page?

    (Yes/No button)

    I get this error when I open EM on the box itself, I change the view mode close EM and open EM and change it to taskpad and there is no error - however after a little while when I reconnect, I get the same message again.  From a client machine, I have not encountered this error.  Is this a bug?  I tried searching google, but did not find anything of significance.



  • Hi Vik,

    I have not had this problem occur, but maybe that's because I rarely use the Taskpad view.  Some people who have had this problem have worked around it by doing a little tap-dance in the GUI.  Something like this:

    1. Switch the view for the affected database to something other than Taskpad (using the View menu).
    2. Close and then re-open Enterprise Manager.
    3. Open the affected database and switch it back to Taskpad view.

    Have you tried this kind of thing?

    Good luck!


  • Hello Chris,

    I have tried your suggestion a few times and it works for a while and then I get the same error again.

  • Welcome to the club.

    At first I thought this in an issue with some service pack, because it disappeared with applying SP3. But after some time it happened again.

    Well, the good thing about it is, that it keeps me from using EM


    Frank Kalis
    Microsoft SQL Server MVP
    My blog:[/url]

  • Well, the good thing about it is, that it keeps me from using EM.

    Funny, Frank. 

    But he's right (he's always right, you know).  Vik, you're on SQLServerCentral, so obviously you're a Database Hero ... why use EM at all, let alone Taskpad View?  There's nothing like setting up replication, Agent jobs, DTS jobs, Database Maintenance Plans, or Full-Text Indexing through OSQL to put hair on your proverbial chest (or whatever the appropriate gender-neutral metaphor would be).

    Yes, I'm joking.  And no, I never use the taskpad.  And ... well, yes, I use the Command Prompt (or even a bash or ksh prompt) as much as I use Windows Explorer ... even in Windows.  There.  I've got that off my (hairy) chest now.

    Somehow, I don't think this post is really going to help Vik very much, but I feel like I've been through some kind of therapy myself.  Thanks.  I will mercifully bring this to an end with one more comment ...

    I can't find any better information about this problem than what I found yesterday.    Vik, let us know if you find any better ideas.  I saw one person who suggested turning off script execution for IE (!).  That might fix one problem, but ...

    Seriously, good luck.


  • Yes, it helps for some time, but then again...

    Another advise you shouldn't take too serious, is to install client tools anew , but then again.

    Meanwhile I suspect there is a higher authority above that has mercy with us.

    EM is not the first choice  

    Hey, I'm getting into weekend mood, so forgive me this post.




    Frank Kalis
    Microsoft SQL Server MVP
    My blog:[/url]

  • OK, as long as we're wayyy off-topic ... Frank, why do I get a nasty-gram when I try to visit  Like so:


    You don't have permission to access / on this server.

    Apache/1.3.27 Server at Port 80

    • Because some b*stards hacked the server last weekend.
    • I don't have a current backup of the content


    Frank Kalis
    Microsoft SQL Server MVP
    My blog:[/url]

  • Yes, Staying on the thread

    Agreed - I don't use EM very often - generally just to use the taskpad view to keep an eye on trans log growth when I am running a monstrous script.  But the error the other day threw me off and wondered if there was a resolution to it.  No biggie - I guess I can live without it.

    Peace guys.


Viewing 9 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic. Login to reply