Getting the "something went wrong. Please Try again Later" message

  • Gary04Z06

    SSC Rookie

    Points: 37

    Trying to add a new data source and getting the message "something went wrong. Please Try again Later".  I can access reports already there, but can't connect to the server from reporting services either.  Couple of things in the log I notice, how do I fix?

    Microsoft.ReportingServices.Portal.WebHost!configmanager!7!06/12/2019-15:18:46:: e ERROR: Missing or Invalid ExtendedProtectionLevel setting

    e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: , Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions granted to user 'PBIUser' are insufficient for performing this operation.;

    (Don't know who user PBIUser is)

     

    e ERROR: [zcdgr7dc]: OData exception occurred: System.Net.WebException: The request failed with HTTP status 503: Service Unavailable.

     

     

    Thanks,

  • Sue_H

    SSC Guru

    Points: 90165

    PBIUser is usually in reference to Power BI User.

    But the extended protection error, check your rsreportserver.config file and make sure you have the necessary attributes in the file as explained in the following:

    Extended Protection for Authentication with Reporting Services

     

    Sue

  • Gary04Z06

    SSC Rookie

    Points: 37

    Ah, thanks, forgot about Power BI.  I'll review the link you posted, thanks,

  • Gary04Z06

    SSC Rookie

    Points: 37

    Here is what was in the config file:

    <Authentication>

    <AuthenticationTypes>

    <RSWindowsNegotiate/>

    </AuthenticationTypes>

    <EnableAuthPersistence>true</EnableAuthPersistence>

    <RSWindowsExtendedProtectionLevel></RSWindowsExtendedProtectionLevel>

    <RSWindowsExtendedProtectionScenario></RSWindowsExtendedProtectionScenario>

    </Authentication>

  • Sue_H

    SSC Guru

    Points: 90165

    And there is nothing in the tags which is the problem. Try using:

    <Authentication>

    <RSWindowsExtendedProtectionLevel>Allow</RSWindowsExtendedProtectionLevel>

    <RSWindowsExtendedProtectionScenario>Proxy</RSWindowsExtendedProtectionLevel>

    </Authentication>

    I don't know your configuration so if you aren't using extended protection, you would still need the tags but set the ExtendedProtectionLevel to Off instead of Allow

    Sue

     

  • Gary04Z06

    SSC Rookie

    Points: 37

    Thanks, I changed to what you have listed, and the service won't start up now.  It's a pretty basic config, just stood it up a couple of weeks ago and only have some basic reports on there now, we aren't very complicated.  thanks,

  • Sue_H

    SSC Guru

    Points: 90165

    Did you also try what I mentioned in the last sentence with setting it to off:

    <RSWindowsExtendedProtectionLevel>Off</RSWindowsExtendedProtectionLevel>

     

    Sue

  • Gary04Z06

    SSC Rookie

    Points: 37

    I don't think I tried:

    <Authentication>

    <RSWindowsExtendedProtectionLevel>Off</RSWindowsExtendedProtectionLevel>

    <RSWindowsExtendedProtectionScenario>Proxy</RSWindowsExtendedProtectionLevel>

    </Authentication>

     

    Will do that now.  Seems like every time I change the confg file, it fails to start the service though.

  • Gary04Z06

    SSC Rookie

    Points: 37

    Changing to "off" did it!  Thanks for your help!!!

  • Sue_H

    SSC Guru

    Points: 90165

    Your welcome and thanks for posting back!

    Sue

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic. Login to reply