Failed to notify ''operator name'' via email?

  • zn

    SSC Journeyman

    Points: 85

    Fantastic, that did the trick.

    Thanks very much

  • Kai-437703

    SSC-Addicted

    Points: 447

    Many thanks for that. You've saved me many hours of looking for the solution 😀

  • RaviG

    Valued Member

    Points: 61

    Thanks a lot guys. Made the suggested change it works now.

    You made my day 😎

  • Klaasjan van Lenthe

    Valued Member

    Points: 64

    A restart was enough (after activating dbmail), thanks!

  • Matt Connolly

    SSC-Addicted

    Points: 499

    Thanks Henrik - that's been bugging me for months!

  • peters-lewisp

    SSC-Addicted

    Points: 408

    Very nice. Nothing in my instructions about setting this up said anything about needing to enable Database Mail by checking that box. Thank you, Henrik!

  • Henrik Staun Poulsen

    SSCertifiable

    Points: 6339

    Even a blind hen can sometimes find her corn.

    Thank you all for the kind words.

    Best regards,

    Henrik Staun Poulsen

    Stovi Software

  • Andrius-344768

    SSC Rookie

    Points: 45

    Thanks.

  • peterw-929325

    SSC Journeyman

    Points: 98

    Awesome, thanks a TON!

  • M Murphy

    SSC Enthusiast

    Points: 176

    Thanks! You saved the bacon.

  • ratnaj

    SSC Journeyman

    Points: 85

    Hey,

    This is very very helpful...I really appreciate it.

  • maccenon

    Valued Member

    Points: 72

    Thanks!!

  • dhudrlik

    Valued Member

    Points: 57

    Thanks Henrik.

  • dyfhid

    SSC Enthusiast

    Points: 160

    I know this thread is old, but this is exactly why it is so important to have this resource.

    I am a relatively new, self taught DBA, totally relying on sites like SQL Server Central for my training, and I had the problem that started this thread this morning - a job failed, and failed to email me about it, though I thought I had everything set up perfectly, including turning on Database mail in SQL Agent --> Properties. The only step I didn't do, and didn't see documented ANYWHERE but here, was to restart the SQL Server Agent.

    My heartfelt thanks go out, first to the person who posted that nugget, and second to the whole SQL Server community, for their willingness to help! Every one of you is greatly appreciated!

  • cherylf

    SSC Enthusiast

    Points: 122

    I struggled with this for most of the day yesterday. I searched and searched, googled and googled, with no workable solution. Just about every thread and blog I read recommended restarting the SQL Server Agent and this seemed to work for most people, but alas, would not work for me. Today, I came in with some fresh coffee and fresh perspective and figured it out.

    Using SS2K8, Windows Server 2008, 32x, everything lives on one machine.

    Sending a test email from Database mail worked.

    Message from Job History:

    "The job succeeded. The Job was invoked by User...bla bla bla...NOTE: Failed to notify 'me' via email."

    From Agent Error Log:

    "[264] An attempt was made to send an email when no email session has been established."

    Tried the following Solutions:

    In SQL Server Agent Properties >> Alert System >> checked Enabled mail profile.

    In Surface Area Configuration (which has been moved to Facets in SS2K8, btw) >> DatabaseMailEnabled = True.

    Deleted and recreated both mail profile and operator.

    Restarted Server Agent like a bazillion times.

    The ultimate solution (I can tell you are on the edge of your seat, nice desk chair by the way, no, really):

    Under Database Mail Configuration >> SMTP Authentication >> changed from Basic authentication to Anonymous authentication >>restarted Server Agent >>crossed fingers for good luck.

    No, seriously, that was it. Don't ask me why it worked, but it worked. Hopes this helps someone.

Viewing 15 posts - 16 through 30 (of 76 total)

You must be logged in to reply to this topic. Login to reply