Failed to notify ''operator name'' via email?

  • A J-145309

    Say Hey Kid

    Points: 675

    Following command sends email fine:

    EXECUTE msdb.dbo.sp_notify_operator @name=N'operator name',@body=N'test

    message'

    However, SQL Job with a notification to above operator doesn't work.

    Job history comfortably mentions following with no other clues:

    NOTE: Failed to notify 'operator name' via email.

    What's wrong here, any ideas??

    Thanks

    AJ

  • This was removed by the editor as SPAM

  • Henrik Staun Poulsen

    SSCertifiable

    Points: 6339

    I just had the same problem.

    I had to enable DatabaseMail on the SQL Server Agent -> properties -> Alert System  (check the checkbox), and then restart SQL Server Agent.

    It works now, thanks to a posting by "Johnny" in microsoft.public.sqlserver.server with the topic "How to setup Operator for sending alerts?"

    HIH

    Henrik Staun Poulsen

  • Gerd Hoefler

    SSC Enthusiast

    Points: 117

    Hi all,

    some time ago i had the same problem.

    I fixed this and make a docu to solve this.

    But i have no idea how i can post this document here.

    If everyone would have this, send me a mail: gerd.hoefler@gmx.at

    Gerd

  • omhoge

    SSCertifiable

    Points: 5416

    Thank you henrik staun poulsen.

    That was a big help!

    Skål - jh

  • RJ-282713

    SSC Enthusiast

    Points: 107

    Thanks so much henrik staun poulsen. You saved my day.

  • Susan harrod

    SSC Enthusiast

    Points: 117

    It helped me too!  Thanks a bunch!

  • Ken Adams-387824

    SSC Journeyman

    Points: 91

    I am a new installer and configurater of SQL 2005 and just tuned in today and you guys really helped me with the Database Mail feature, to get it configured correctly.

    Thanks a million to all!!!!!!!! 

  • nmederich

    Old Hand

    Points: 347

    Thank you Henrik. It works now!

  • Grazyna Trzesicka-343230

    SSC Enthusiast

    Points: 109

    thanks a lot!

  • LiLo-467201

    SSC Enthusiast

    Points: 101

    Big thanks to you!!!

  • Michael Hohman

    Valued Member

    Points: 73

    Helped out another newbie!

  • Martijn van Spanje

    SSC Journeyman

    Points: 90

    Thanks Henrik.

    The SQL Server Surface Area Configuration - Surface Area Configuration for Features - Database Engine - Database Mail was enabled, the msdb..sp_send_dbmail gave no errors, but I couldn't find the problem.

    Enabling the SQL Server Agent -> properties -> Alert System, and then restart SQL Server Agent was the solution.

  • Duncan Njuguna

    Valued Member

    Points: 59

    thanks alot this worked right away:P

  • Amir-506445

    SSC Rookie

    Points: 46

    Thanks M8, you saved my time, I had done that on another instance but crazy me, thanks indeed.

Viewing 15 posts - 1 through 15 (of 76 total)

You must be logged in to reply to this topic. Login to reply