Error while running 2005 upgrade advisor

  • MANU-J.

    SSC-Dedicated

    Points: 31126

    Hi,

    When I am trying to run 2005 upgrade advisor wizard for my sql 2000(devloper edition) its failing at last step(Analyze SQL Server).

    Below mentioned error message is getting logged under eevnt viewer:

    EventType clr20r3, P1 bpacmd.exe, P2 2005.90.2047.0, P3 443f5935, P4 bpacmdx, P5 9.0.242.0, P6 443f5932, P7 7, P8 7a, P9 system.io.filenotfoundexception, P10 NIL.

    I am not able to understand what it states and what is required to make its run successful.

    When I try to upgrade the existing 2k instance directly using 2005 setup files its failing at verification step with error(upgrade advisor returned -1).

    I have another instance of sql 2008 release code0 installed on same box too(and also with SQL Server 2008 upgrade advisor wizard).

    Can this be a problem as both are there on one machine?

    Please help.....

    MJ

  • tucankur

    SSC Journeyman

    Points: 99

    There is a folder called BPA and under the child folder called "binn" there is a file called bpnclient.dll. Create a new folder under the main BPN folder called the bpnclient and move this file into that folder from the binn folder and rerun your upgrade...it should work!

  • MANU-J.

    SSC-Dedicated

    Points: 31126

    I had to uninstall and install the .NET framework again to make it work. Sorry, I got your suggestion too late.

    Thanks again,

    Manu

  • Sqlish

    Ten Centuries

    Points: 1085

    Hi There i have the same issue when i run the upgrade advisor the sql server, i tried creating a new folder named BPNCLIENT and copied the .dll (BPAClient.dll), however i still have the same issue...

    could you please help me out on this...

    =======================================================================================

    Visit my technical reference; you might find some of your issues already documented.

  • MANU-J.

    SSC-Dedicated

    Points: 31126

    MANU (10/20/2008)


    I had to uninstall and install the .NET framework again to make it work. Sorry, I got your suggestion too late.

    Thanks again,

    Manu

    Follow the above advice if you tried every other option available.

    MJ

  • Sqlish

    Ten Centuries

    Points: 1085

    Hi Manu,

    I tried the 'bpaclient' folder instead of 'bpnclient' and it worked. I thing it was a typo in your solution.

    Now i ran the upgrade advisor succesfully, and fixed the pre upgrade issues, however during the actual upgrade i am getting the below error:

    I am upgrading sql server 2000 std edition to sql server 2005 std edition.

    "

    TITLE: Microsoft SQL Server Setup

    ------------------------------

    UpgradeAdvisor returned -1 .

    Error message:

    For help, click: http://go.microsoft.com/fwlink?LinkID=20476&ProdName=Microsoft+SQL+Server&ProdVer=9.00.1399.06&EvtSrc=setup.rll&EvtID=SQLSetup90&EvtType=29552

    ------------------------------

    BUTTONS:

    OK

    ------------------------------

    "

    The link given in the error says i have choosen mixed authentication mode and asks me to set a strong password for 'sa'.

    I tried setting up a strong password for 'sa' but no use.

    then i changed the authentication mode of the sql server 2000 to windows authentication and ran the setup again, only to see the same error again...

    Could you please help me on this quickly, i am in the middle of the upgrade change window.

    Thanks in advance

    Suleman

    =======================================================================================

    Visit my technical reference; you might find some of your issues already documented.

  • MANU-J.

    SSC-Dedicated

    Points: 31126

    From googling:

    Several simple solution steps:

    1*. Go to Administrative Tools / Domain Security Policy :: Security Settings | Account Policies | Password Policy

    2*. Ensure "Minimum password length" and "Password must meet complexity requirements" set to "Not Defined" state.

    * Skip this steps if you don't have domain controller.

    3. Go to Administrative Tools / Local Security Policy :: Security Settings | Account Policies | Password Policy

    4. Turn "Minimum password length" to zero and "Password must meet complexity requirements" to "Disable"

    5. Go to SQL Installation window and press "Retry".

    6. After installation successfully done, turn changed security settings from steps 1-4 back.

    7. Have fun.

    MJ

  • MANU-J.

    SSC-Dedicated

    Points: 31126

    Or

    Make sure you follow restrictions mentioned at http://msdn.microsoft.com/en-us/library/ms161959(SQL.90).aspx

    MJ

  • Sqlish

    Ten Centuries

    Points: 1085

    I am not authorized to try the solution given abt the windows group policy...

    however i tried the sql server strong password thing, and i still have the same error.

    =======================================================================================

    Visit my technical reference; you might find some of your issues already documented.

  • MANU-J.

    SSC-Dedicated

    Points: 31126

    Have you logged in with admin privileges on this box?

    If the machine is not a domain controller then you must be able to do the following changes:

    3. Go to Administrative Tools / Local Security Policy :: Security Settings | Account Policies | Password Policy

    4. Turn "Minimum password length" to zero and "Password must meet complexity requirements" to "Disable"

    5. Go to SQL Installation window and press "Retry".

    6. After installation successfully done, turn changed security settings from steps 1-4 back.

    7. Have fun.

    MJ

  • Sqlish

    Ten Centuries

    Points: 1085

    Ooops, we have different teams authorized for different tasks, i am the from dba team and there is another team which manages and maintains the windows...

    Any other possible solution we can think of for now apart from this ?

    =======================================================================================

    Visit my technical reference; you might find some of your issues already documented.

  • MANU-J.

    SSC-Dedicated

    Points: 31126

    In case you have any other 2005 instance installed on this machine then try creating one login there and see if it accepts the password you supply for it. Make sure enforce password policy option is checked.

    In case you don't have any other 2005 instance then try specifying your login password to see if it accepts it or not. Also, once you specify the new password on 2000 close the existing upgrade window and start again(just a guess not sure if it really matters).

    MJ

  • Sqlish

    Ten Centuries

    Points: 1085

    Tried all you mentioned earlier, no gains yet...

    =======================================================================================

    Visit my technical reference; you might find some of your issues already documented.

  • MANU-J.

    SSC-Dedicated

    Points: 31126

    I assume you restarted the sql 2000 after changing its authentication mode. Also, you started afresh once its restarted

    MJ

  • Sqlish

    Ten Centuries

    Points: 1085

    I Changed the authentication mode, applied a strong password, added the flag -T4606, recycled sql service and started setup of SQL Server 2005 to upgrade the existing default instance.

    I end up gettting the same error again.

    It says setup.rll is the source file of the error.

    =======================================================================================

    Visit my technical reference; you might find some of your issues already documented.

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic. Login to reply