Count of Models measure - how do I hide it?

  • Jonas Bergström

    SSC-Addicted

    Points: 433

    How do I get rid of the automaticly showing measure in the excel/powerpivot pivottable fieldlist?

    "Values"

    ___Count of Models

    My customer doesn't want it there.

    Edit: Oh, forgot to mention, it's 2012/Denali CTP3.

  • Raunak Jhawar

    SSCoach

    Points: 15701

    Very easy. Glad you asked.

    Step 1: Right Click the .BIM file and select View Code

    Step 2: Ctrl+F to find __Count of Model

    Step 3: Comment the entire Command block that defines this measure

    Step 4: Save the change made

    Step 5: Now open the .BIM file again --> Build -->Deploy

    Note: This is a default measure auto created having value as 1

    Hope this helps. Feel free to ask anything you wish.

    Regards/Raunak
    Now a member of Linkedin

    Please visit the all new Performance Point Forum
    Please visit the all new Data Mining and Business Analytics Forum

  • Jonas.SQL

    SSC Veteran

    Points: 263

    I saw that it is fixed now in RC0. Great! :w00t:

    https://connect.microsoft.com/SQLServer/feedback/details/712481/-count-of-model-in-tabular-model#tabs

    Though my "old" models, created in CTP3 doesn't get "cured" just by being edited in SSDT CTP4 or by being deployed to a RC0 instance - it still needs your fix to hide the "___Count of Models"-measuregroup in the excelsheet. How do I comment a row in XML? /**/ or -- or something else?

  • Raunak Jhawar

    SSCoach

    Points: 15701

    Jonas.SQL (12/12/2011)


    I saw that it is fixed now in RC0. Great! :w00t:

    https://connect.microsoft.com/SQLServer/feedback/details/712481/-count-of-model-in-tabular-model#tabs

    Though my "old" models, created in CTP3 doesn't get "cured" just by being edited in SSDT CTP4 or by being deployed to a RC0 instance - it still needs your fix to hide the "___Count of Models"-measuregroup in the excelsheet. How do I comment a row in XML? /**/ or -- or something else?

    Yes I had riased the issue in MS Connect.

    Follow the steps as above and the default measure will not pop up in Excel or SSMS

    again, search of <Command> in .BIM code file --> comment the <Command> XML node that defines [__Count of Models] and deploy the solution again.

    Regards/Raunak
    Now a member of Linkedin

    Please visit the all new Performance Point Forum
    Please visit the all new Data Mining and Business Analytics Forum

  • Jonas.SQL

    SSC Veteran

    Points: 263

    I tried like this, but it still shows. Maybe excel has some similar default "connector" for this default measure on that side?

    <!--

    <Command>

    <Text>CALCULATE;

    CREATE MEMBER CURRENTCUBE.Measures.[__Count of Models] AS 1;

    ALTER CUBE CURRENTCUBE UPDATE DIMENSION Measures, Default_Member = [__Count of Models]; </Text>

    </Command>

    -->

  • Raunak Jhawar

    SSCoach

    Points: 15701

    Correct...now save the .BIM file

    Next close this file

    Now open the solution explorer and double clink on Model.BIM file (or your .BIM) file

    Build and deploy your project

    Observe the change

    OR

    Click here

    Regards/Raunak
    Now a member of Linkedin

    Please visit the all new Performance Point Forum
    Please visit the all new Data Mining and Business Analytics Forum

  • Jonas.SQL

    SSC Veteran

    Points: 263

    Did follow your directives exactly. Next time I doubleclick .bim file it opens correctly. I build and deploy, but now I cannot use the analyze in excel function, it says some security issue has occurred and the data connection is disabled. If I create a new excel sheet, data connection, AS Server, I now have my self-created meaures listed, but still also has the ___Count of Models.

    I close the solution edit the .bim file back as it were, save, open in ssdt, build, deploy, and it has reverted to same old - same old, ie analyze-in-excel is working again, still showing ___Count of Models.

  • Raunak Jhawar

    SSCoach

    Points: 15701

    Ok...let's do it once again

    Comment the block-->Save the file in XML edit mode-->Make sure you have atleast one calculated measure defined in the tabular project(else the project will not open in excel)-->now double click the model.bim file-->build and deploy

    If you have followed exactly the steps, the measure will not appear in excel and in ssms

    Regards/Raunak
    Now a member of Linkedin

    Please visit the all new Performance Point Forum
    Please visit the all new Data Mining and Business Analytics Forum

  • Jonas.SQL

    SSC Veteran

    Points: 263

    Tried it once more and sorry, that doesn't work in my project. Doesn't really matter though. I'm going RC0 with it. Rebuilding the project, model and everything from scratch.

    Thank you for your support, but I'll leave it with that.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic. Login to reply