Could not locate entry in sysdatabases for database.

  • Nitin Gupta - SQL DBA

    Ten Centuries

    Points: 1058

    Hi All,

    Please help me as I'm getting this error :

    "Could not locate entry in sysdatabases for database 'abcd4567_db' . No entry found with that name. Make sure that the name is entered correctly"

    when application team trying to access SQL Database through application its getting stuck in this portion. We migrated few databases from SQL 2000 to SQL 2005 with all setting few months ago and its work at that moment.

    Please provide your suggesstion.

    Regards,

    Nitin

    Thanks & Regards,

    Nitin Gupta
    SQl Server (7.0,2000,2005) - Sr. DBA
    HCL Technologies, India

  • crazy4sql

    SSCoach

    Points: 19590

    is it case sensitive server/database?

    if the database like sharepoint database then put them in [ ] code.

    Other option, if you able to see the database, right click on table and go to select top 1000 rows. You will know what is your database name should look like

    ----------
    Ashish

  • Nitin Gupta - SQL DBA

    Ten Centuries

    Points: 1058

    Thanks for the reply, but its not the case sencitive database\server.

    Complete Error

    --------------

    06:49:09 Database system user [sa] does not have the necessary permissions on the DB server

    06:49:09 No permission to 'db_owner' Failed to execute SQL 'use 'dbcr_axsss2009003_abc_errordb_ select IS_MEMBER ('db_owner') AS "result"' Error=Failed SQL: /* ~~QC */ use dbcr_axsss2009003 ...

    06:49:09 14_ams_release_ select IS_MEMBER ('db_owner') AS "result" [Mercury][SQLServer JDBC Driver][SQLServer]Could not locate entry in sysdatabases for database 'dbcr_axsss2009003_abc_errordb_'. No entry foun ...

    06:49:09 d with that name. Make sure that the name is entered correctly.

    Regards,

    Nitin

    Thanks & Regards,

    Nitin Gupta
    SQl Server (7.0,2000,2005) - Sr. DBA
    HCL Technologies, India

  • crazy4sql

    SSCoach

    Points: 19590

    but if you able to see the database then can you try to do--- select top 100 from a perticular table using gui(SSMS).

    Also if the application was running till yesterday properly then is thier any change in secuirty credentials overnight?

    Could be the possibility that sa account is not enabled

    try this code

    ALTER LOGIN sa ENABLE

    GO

    ----------
    Ashish

  • Nitin Gupta - SQL DBA

    Ten Centuries

    Points: 1058

    Ashish,

    When I'm trying to fetch the records by right client is working for me and when its fetching through application ....failure.

    The database name is automatically fetch by application we're not providing it manually.

    Again this solution is not work for me. 🙁

    Thanks & Regards,

    Nitin Gupta
    SQl Server (7.0,2000,2005) - Sr. DBA
    HCL Technologies, India

  • crazy4sql

    SSCoach

    Points: 19590

    do one thing,

    run the profiler and make it specific to that database and then from front end try to login and on back end your profiler will capture the events related to specific database.

    Events to capture are :-

    •RPC:Completed

    •SP:StmtCompleted

    •SQL:BatchStarting

    •SQL:BatchCompleted

    ----------
    Ashish

  • crazy4sql

    SSCoach

    Points: 19590

    have you found the solution of the problem as I am interested to know the investigation done and suggested.

    ----------
    Ashish

  • varunchopra.apj

    Grasshopper

    Points: 14

    Nitin Gupta - SQL DBA - Monday, September 27, 2010 9:48 AM

    Hi All,Please help me as I'm getting this error :"Could not locate entry in sysdatabases for database 'abcd4567_db' . No entry found with that name. Make sure that the name is entered correctly" when application team trying to access SQL Database through application its getting stuck in this portion. We migrated few databases from SQL 2000 to SQL 2005 with all setting few months ago and its work at that moment.Please provide your suggesstion.Regards,Nitin

    Hi All

    I faced the same issue.

    We need to use Square brackets for database name

    ie

    use [database]

    instead of

    use database

    Hope it helps.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic. Login to reply