Can't deploy reports from BIDS to reporting services

  • akumbabarns

    SSChasing Mays

    Points: 632

    I am new to SSRS. Been able to design a report using BIDS. When I try to deploy the report using BIDS, the reporting servics login screen keeps prompting for a username and password.

    Various attempts to connect using various login credentials failed and the screen persists.

    I also tried to use the report manager but it only displays a blank screen without the needed options.

    Attempt to use the Report Server url displays the following error:

    "The permissions granted to user 'DBA\Barns' are insufficient for performing this operation. (rsAccessDenied)"

    My report server service account is "Network Service".

    I'll appreciate any urgent help.

    Regards

  • Rock from VbCity

    Hall of Fame

    Points: 3991

    Hi akumbabarns

    I had a similar problem early this week on a freshly installed SSRS 2008 on my development laptop (Windows 7); I will explain the steps I did to resolve my issue.

  • Open Reporting Services Configuration Manager
    • Service Account Local System

      Report Manager: http://localhost:80/Reports_InstanceName

      Close Reporting Services Configuration Manager

      We were reviewing the parameters we will need later

  • Disable User Account Control Setting
    • Click on the Start button

      Type UAC on the Search program and files

      Click on User Account Control Setting option

      Pull the lever down to Never Notify

      Reboot your workstation

      We will reset the UAC setting once we finish the whole procedure

  • Configuring Report Manager
    • Start your browser Internet Explorer

      Type in your Report Manager URL (the one identified on the first block of this procedure)

      The Report Manager now renders the Home folder with the Contents and Properties tabs

      Click on the Properties tab.

      Click on the New Role Assignment button

      Assign your account domain/user_name to the Content Manager role.

      Click on the Ok button to save the new user-role

      Click on the Site Settings link located at the top-right of the browser's window

      Click on its Security option located on the left pane

      Add yourself to the System Administrator and System User roles.

      Click on the Ok button to save the changes

      Close the browser

  • Enable User Account Control Setting
    • Click on the Start button

      Type UAC on the Search program and files

      Click on User Account Control Setting option

      Pull the lever to the same position it has before.[/b]

      Reboot your workstation

  • Open BIDS and your project
    • On the solution explorer, right-click on your project node

      Click on the Properties node

      Enter the name for the TargetDataSourceFolder

      Enter the name for the TargetReportFolder

      Enter the target server URL http://localhost/ReportServer_InstanceName

      It is up to you to set the property OverwriteDataSources to true or false

      Click on the Ok button to close the properties window.

    That's it, you should be able to deploy your reports to your local report server.

    You will need to enter your login credential when accessing the Report Manager via the browser.

    Hope this helps.

    Arnaldo

    Hope this helps,
    Rock from VbCity

  • akumbabarns

    SSChasing Mays

    Points: 632

    THANKS MAN.

    You made my day.:satisfied:

  • akumbabarns

    SSChasing Mays

    Points: 632

    Hello,

    I still have some issues with this.

    I realized that after resetting the UAC settings to the default value, the problem persists.

    I also realized that I still can't Deploy with BIDS since the login prompt is still there. I have reverted to using the Report Manager to upload reports that I've designed in BIDS. Since that is possible and easy.

    Will appreciate your usual assistanc.

  • Rock from VbCity

    Hall of Fame

    Points: 3991

    Please tell us what happens after you disabled UAC, Where you able to login into Report Manager? Did it show you the Contents and Properties tabs?

    It is a long procedure, and the step about disabling UAC and accessing Report Manager is the most important, that will be the first step in troubleshooting your issue.

    Hope this helps

    Hope this helps,
    Rock from VbCity

  • akumbabarns

    SSChasing Mays

    Points: 632

    Hello Rock,

    After disabling UAC, I was able to login to Report Manager. It displayed all the required content. But after I re-enabled it, it didn't display the content again.

  • Rock from VbCity

    Hall of Fame

    Points: 3991

    That's very good akumbabarns

    Once you are at the Report Manager with UAC disabled you have to change its settings to add your account as a Content Manager System Administrator and System User

    You will do that in two stages:

    1. Clicking on the Properties tab (on the left of the screen, under the Home folder)

    2. Clicking on the Site Settings link (top-right of the screen)

    Properties

    Here, you assign your account as a Context Manager

    You should enter your account as DOMAIN/login (look at the attached picture)

    Site Settings

    Here you assign your account as: System Administrator and System User

    You should enter your account as DOMAIN/login (look at the attached picture)

    - o -

    Once you complete these configurations, reset the UAC as it was, then reboot the machine, once the machine is back you should be able to access the Report Manager by login with your account and password, you should be able to get a Report Manager with all the admin controls, as they appear at the top of the attached image.

    - o -

    The attached picture, contains 3 areas; the top is the Report Manager, its middle is the screen you will get when assigning your account to the Context Manager, the bottom is when you assign your account to the System Administrator and System User.

    Let us know the outcome to move to the next section of the procedure.

    Hope this helps,

    Rock from VbCity.

    Hope this helps,
    Rock from VbCity

  • akumbabarns

    SSChasing Mays

    Points: 632

    Hello Rock,

    Just tried the steps as u directed.

    See attached screen shots.

    But after re-enabling the UAC settings and restarting the system, report manager doesn't display the Content and Properties tabs any

    longer.

  • Rock from VbCity

    Hall of Fame

    Points: 3991

    Hi akumbabarns

    Is DBA the domain your account is assigned to? it should be the same, it is the same domain you are assigned when login to your workstation; let me explain my environment, it is a laptop with MS SQL 2008 installed, my laptop name is jupiter, and it turned to be the domain I should be using, although I have a local area network, with a different domain name.

    If you are unable to access the Report Manager once UAC is re-enabled, then you should try to use the machine name instead of the DBA.

    Hope this helps,
    Rock from VbCity

  • akumbabarns

    SSChasing Mays

    Points: 632

    Hello Rock,

    DBA is my computer Name.

  • Rock from VbCity

    Hall of Fame

    Points: 3991

    We are on the same page, let's go with the next step, once you UAC is reset back to its original value (enabled) and you had rebooted the machine, you will start your browser (Internet Explorer, it will be better than anything else at the moment), the you will navigate to your Report Manager by entering its URL, I expect it to be something like: http://DBA/Reports (I am not sure is you are using an instance name.

    Now the attached picture show the behavior on my laptop, I get a login screen where I enter my account (without the 'domain' or 'machine' name) and password (I dealt with this issue last week, so, I haven't tried to get rid of this password yet); notice that I drew an arrow to the 'DOMAIN', which is your case, the expected value should be DBA.

    After you enter your login credentials, the Report Manager should show you the 'administration' controls, please let us know.

    Hope this helps,
    Rock from VbCity

  • akumbabarns

    SSChasing Mays

    Points: 632

    Hello Rock,

    I did that and still no luck.

    Please see the attached file.

    I just tried running Internet Explorer as Administrator (by right-clicking on Internet Explorer and selecting "Run as Administrator) and I inputted the login details and it worked.

    How do I go about solving this issue so that I don't need to Run IE as Administrator before it works?.

  • Rock from VbCity

    Hall of Fame

    Points: 3991

    Hi akumbabarns

    I certainly forgot to tell you about IE settings, there are a couple of things you should do.

    1. Add your machine's name to the trusted sites on the Security tab at the Internet Options

    2. Enable Integrated Windows Authentication on the Advanced tab at the Internet Options

    These settings are at the Internet Options, see the pictures below.

    and

    You should close all your IE sessions and re-start it to see these changes applied.

    Once you apply these changes you should be able to use IE without running it as Administrator, and you should get all the Report Management buttons as well.

    The Report Management with all its buttons and controls, you wont see the folders as you have to deploy your project to get them, which is the next step below.

    If you reach this point, "Report Management" with all its controls, the next step is to open your SSRS solution with BIDS, right click on the project name, select properties and change them at described on the picture below.

    It is late here, so I will read your reply tomorrow (6-7 hours from now)

    Hope this helps,
    Rock from VbCity

  • akumbabarns

    SSChasing Mays

    Points: 632

    Hello Rock,

    Thank you so much for your time.

    I've done as directed and it worked well. The Report Manager is working very well now.

    The only issue left now is with BIDS. It is still repeatedly bringing up the Reporting Services login page even after I fill the correct credentials.

    See attachment.

  • Rock from VbCity

    Hall of Fame

    Points: 3991

    Hi akumbabarns

    Take a look at the last picture on my previous message, right-click on your project, click on properties and make sure that the TargetServerURL is http://DBA/ReportServer_MSSQLSERVER08, once you set these parameters you should be able to deploy without entering any credential, and Report Manager should render the Data Sources and the report objects.

    You are almost there 🙂

    Hope this helps,
    Rock from VbCity

  • Viewing 15 posts - 1 through 15 (of 18 total)

    You must be logged in to reply to this topic. Login to reply