Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Can't deploy reports from BIDS to reporting services


Can't deploy reports from BIDS to reporting services

Author
Message
akumbabarns
akumbabarns
Grasshopper
Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)

Group: General Forum Members
Points: 12 Visits: 48
I am new to SSRS. Been able to design a report using BIDS. When I try to deploy the report using BIDS, the reporting servics login screen keeps prompting for a username and password.
Various attempts to connect using various login credentials failed and the screen persists.

I also tried to use the report manager but it only displays a blank screen without the needed options.


Attempt to use the Report Server url displays the following error:
"The permissions granted to user 'DBA\Barns' are insufficient for performing this operation. (rsAccessDenied)"
My report server service account is "Network Service".

I'll appreciate any urgent help.

Regards
Rock from VbCity
Rock from VbCity
SSC-Enthusiastic
SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)

Group: General Forum Members
Points: 127 Visits: 1038
Hi akumbabarns

I had a similar problem early this week on a freshly installed SSRS 2008 on my development laptop (Windows 7); I will explain the steps I did to resolve my issue.

  • Open Reporting Services Configuration Manager

    • Service Account Local System
      Report Manager: http://localhost:80/Reports_InstanceName
      Close Reporting Services Configuration Manager

      We were reviewing the parameters we will need later

  • Disable User Account Control Setting

    • Click on the Start button
      Type UAC on the Search program and files
      Click on User Account Control Setting option
      Pull the lever down to Never Notify
      Reboot your workstation

      We will reset the UAC setting once we finish the whole procedure

  • Configuring Report Manager

    • Start your browser Internet Explorer
      Type in your Report Manager URL (the one identified on the first block of this procedure)
      The Report Manager now renders the Home folder with the Contents and Properties tabs
      Click on the Properties tab.
      Click on the New Role Assignment button
      Assign your account domain/user_name to the Content Manager role.
      Click on the Ok button to save the new user-role

      Click on the Site Settings link located at the top-right of the browser's window
      Click on its Security option located on the left pane
      Add yourself to the System Administrator and System User roles.
      Click on the Ok button to save the changes
      Close the browser


  • Enable User Account Control Setting

    • Click on the Start button
      Type UAC on the Search program and files
      Click on User Account Control Setting option
      Pull the lever to the same position it has before.[/b]
      Reboot your workstation

  • Open BIDS and your project

    • On the solution explorer, right-click on your project node
      Click on the Properties node
      Enter the name for the TargetDataSourceFolder
      Enter the name for the TargetReportFolder
      Enter the target server URL http://localhost/ReportServer_InstanceName
      It is up to you to set the property OverwriteDataSources to true or false
      Click on the Ok button to close the properties window.


    That's it, you should be able to deploy your reports to your local report server.
    You will need to enter your login credential when accessing the Report Manager via the browser.

    Hope this helps.
    Arnaldo

    Hope this helps,
    Rock from VbCity
    akumbabarns
    akumbabarns
    Grasshopper
    Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)

    Group: General Forum Members
    Points: 12 Visits: 48
    THANKS MAN.
    You made my day.Satisfied
    akumbabarns
    akumbabarns
    Grasshopper
    Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)

    Group: General Forum Members
    Points: 12 Visits: 48
    Hello,

    I still have some issues with this.
    I realized that after resetting the UAC settings to the default value, the problem persists.
    I also realized that I still can't Deploy with BIDS since the login prompt is still there. I have reverted to using the Report Manager to upload reports that I've designed in BIDS. Since that is possible and easy.

    Will appreciate your usual assistanc.
    Rock from VbCity
    Rock from VbCity
    SSC-Enthusiastic
    SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)

    Group: General Forum Members
    Points: 127 Visits: 1038
    Please tell us what happens after you disabled UAC, Where you able to login into Report Manager? Did it show you the Contents and Properties tabs?

    It is a long procedure, and the step about disabling UAC and accessing Report Manager is the most important, that will be the first step in troubleshooting your issue.

    Hope this helps

    Hope this helps,
    Rock from VbCity
    akumbabarns
    akumbabarns
    Grasshopper
    Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)

    Group: General Forum Members
    Points: 12 Visits: 48
    Hello Rock,

    After disabling UAC, I was able to login to Report Manager. It displayed all the required content. But after I re-enabled it, it didn't display the content again.
    Rock from VbCity
    Rock from VbCity
    SSC-Enthusiastic
    SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)

    Group: General Forum Members
    Points: 127 Visits: 1038
    That's very good akumbabarns

    Once you are at the Report Manager with UAC disabled you have to change its settings to add your account as a Content Manager System Administrator and System User

    You will do that in two stages:

    1. Clicking on the Properties tab (on the left of the screen, under the Home folder)
    2. Clicking on the Site Settings link (top-right of the screen)

    Properties
    Here, you assign your account as a Context Manager
    You should enter your account as DOMAIN/login (look at the attached picture)

    Site Settings
    Here you assign your account as: System Administrator and System User
    You should enter your account as DOMAIN/login (look at the attached picture)

    - o -
    Once you complete these configurations, reset the UAC as it was, then reboot the machine, once the machine is back you should be able to access the Report Manager by login with your account and password, you should be able to get a Report Manager with all the admin controls, as they appear at the top of the attached image.

    - o -

    The attached picture, contains 3 areas; the top is the Report Manager, its middle is the screen you will get when assigning your account to the Context Manager, the bottom is when you assign your account to the System Administrator and System User.

    Let us know the outcome to move to the next section of the procedure.

    Hope this helps,
    Rock from VbCity.

    Hope this helps,
    Rock from VbCity
    Attachments
    akumbabarns_01.png (14 views, 73.00 KB)
    akumbabarns
    akumbabarns
    Grasshopper
    Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)

    Group: General Forum Members
    Points: 12 Visits: 48
    Hello Rock,

    Just tried the steps as u directed.
    See attached screen shots.
    But after re-enabling the UAC settings and restarting the system, report manager doesn't display the Content and Properties tabs any
    longer.
    Attachments
    ScreenShot.pdf (14 views, 102.00 KB)
    Rock from VbCity
    Rock from VbCity
    SSC-Enthusiastic
    SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)SSC-Enthusiastic (127 reputation)

    Group: General Forum Members
    Points: 127 Visits: 1038
    Hi akumbabarns

    Is DBA the domain your account is assigned to? it should be the same, it is the same domain you are assigned when login to your workstation; let me explain my environment, it is a laptop with MS SQL 2008 installed, my laptop name is jupiter, and it turned to be the domain I should be using, although I have a local area network, with a different domain name.

    If you are unable to access the Report Manager once UAC is re-enabled, then you should try to use the machine name instead of the DBA.

    Hope this helps,
    Rock from VbCity
    akumbabarns
    akumbabarns
    Grasshopper
    Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)Grasshopper (12 reputation)

    Group: General Forum Members
    Points: 12 Visits: 48
    Hello Rock,

    DBA is my computer Name.
    Go


    Permissions

    You can't post new topics.
    You can't post topic replies.
    You can't post new polls.
    You can't post replies to polls.
    You can't edit your own topics.
    You can't delete your own topics.
    You can't edit other topics.
    You can't delete other topics.
    You can't edit your own posts.
    You can't edit other posts.
    You can't delete your own posts.
    You can't delete other posts.
    You can't post events.
    You can't edit your own events.
    You can't edit other events.
    You can't delete your own events.
    You can't delete other events.
    You can't send private messages.
    You can't send emails.
    You can read topics.
    You can't vote in polls.
    You can't upload attachments.
    You can download attachments.
    You can't post HTML code.
    You can't edit HTML code.
    You can't post IFCode.
    You can't post JavaScript.
    You can post emoticons.
    You can't post or upload images.

    Select a forum

































































































































































    SQLServerCentral


    Search