Forum Replies Created

Viewing 15 posts - 23,056 through 23,070 (of 49,552 total)

  • RE: How to rename SQL ServerName?

    madhusudan418 (10/5/2011)


    just try Sp_rename 'oldservername','newservname'

    this should work out for you

    EXEC sp_rename 'Myrlin\SQL2008', 'SomeOtherServer\SQL2008'

    Msg 15225, Level 11, State 1, Procedure sp_rename, Line 338

    No item by the name of 'Myrlin\SQL2008' could be...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Transaction Log Full in Simple Recovery mode

    99zardoz (10/5/2011)


    Just a thought for everyone and more of a question than a suggestion but in this situation would not be worth shrinking the log file with DBCC SHRINKFILE?

    Shrinkfile...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: suspect_pages for userdefined database

    Find out what database is number 59 (query sys.databases). Run the following command on that database and post the full and complete output.

    DBCC CHECKDB (<Database Name>) WITH NO_INFOMSGS, ALL_ERRORMSGS

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: One index, or three?

    MyDoggieJessie (10/4/2011)


    Shouldn't you always want to filter out as much data as possible in multiple table JOINs before even hitting the WHERE clause?

    You're assuming the join clause runs before...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: ALTER COLUMN & Indexes

    As the error says, there is something dependant on the column (an index) which has to be dropped first.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Unable to open SQL 2008 Instance after SP2 applied

    First you have to identify which DB it is (it's highly unlikely to be master). A query of sys.databases will do that. Changing the ownership of a DB is not...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Unable to open SQL 2008 Instance after SP2 applied

    Why, why, why are you trying to alter a login? Your problem is not that the SA account has been renamed. The command you need to run is one to...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Are the posted questions getting worse?

    Jeff Moden (10/4/2011)


    I wonder how many of us there are that try to completely ignore certs and degrees in the interview process?

    I don't. If the person has a relevant certification...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Unable to open SQL 2008 Instance after SP2 applied

    SQLSeTTeR (10/4/2011)


    This part is failing.

    Define 'failing'. I can't see your screen.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Unable to open SQL 2008 Instance after SP2 applied

    Oh, and that command won't fix this error anyway. That SQL command you have is specific to the error that the page talks about, which is not the problem you...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Unable to open SQL 2008 Instance after SP2 applied

    Directory is irrelevant, that is attempting to connect to the default instance because there's no -S parameter.

    sqlcmd /?

    Don't double-click the icon, that doesn't allow switches and options. Open a command...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Unable to open SQL 2008 Instance after SP2 applied

    Are you specifying the correct instance?

    Is the service running (net start doesn't guarantee that it did start, just that the start signal was sent)

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Unable to open SQL 2008 Instance after SP2 applied

    What do you mean 'doesn't start'?

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: inserting data into views

    Make sure that the inserted row qualifies for the view based on the definition of the view.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Unable to open SQL 2008 Instance after SP2 applied

    The reason was that someone, for some strange reason, assigned the login '##MS_PolicyEventProcessingLogin##' to be the owner of a database. There's a way in the following article to get access...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass

Viewing 15 posts - 23,056 through 23,070 (of 49,552 total)