What happened to my SSMS shortcuts in 20.1?

  • I installed SSMS 20.1 and all my trusted keyboard shortcuts don't work anymore...

    <Ctrl>E --> Execute

    <Ctrl>R --> Toggle result pane

    It seems to always wait for the second character in the sequence...

    I tried to reset keyboard settings in tools/options but no change

    Is my install broken?

     

  • SSMS keyboard shortcuts (built-in and custom) are working as usual for me in 20.1.

    What do you mean by the following, exactly?

    It seems to always wait for the second character in the sequence...

    The absence of evidence is not evidence of absence
    - Martin Rees
    The absence of consumable DDL, sample data and desired results is, however, evidence of the absence of my response
    - Phil Parkin

  • If I type <Ctrl>E, it does not do anything and wait for the following character.

    2024-06-12_17-50-09

    Same for <Ctrl>R

     

    Maybe it is linked to a previous incident I had...

    I first installed SSMS 20.1 and worked for a bit.

    Then next time I opened it, it looked like an empty Visual Studio shell.

    Had lost everything to do with SQL.

    I went back to the Install exe and ran repair...

    Maybe I should uninstall/install...

  • Eric Mamet wrote:

    Then next time I opened it, it looked like an empty Visual Studio shell.

    Looking on the bright side, maybe the Dark theme would have been officially implemented in that version 🙂

    But I agree with you; that does sound like a corrupt install.

    The absence of evidence is not evidence of absence
    - Martin Rees
    The absence of consumable DDL, sample data and desired results is, however, evidence of the absence of my response
    - Phil Parkin

  • I tried to uninstall/install but got exactly the same issues

     

    Then I asked a colleague to export his settings through Tools/Options/Import and Export Settings

     

    AND THAT FIXED IT!!!

    Thanks for your help. Much appreciated, as always

Viewing 5 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply