user 'NT AUTHORITY\NETWORK SERVICE' are insufficient for performing this operation

  • Hi All

    I am getting the above error when executing a report to test printing.

    It's a completly new installation, Windows 2008 Server - SQL Server 2008.

    I have tried all the suggestion on the net - mostly they are to do with RSS 2005 - but I have tried and made the necessary changes - however it's still not working -

    We have RSS service being run as a domain user and have tried administrator - so I don't know where the Network Service account is coming from. With RSS not being connected to IIS7 it's also a little hard to get to some of the properties that you used to have with RSS2005 and IIS6.

    If anyone has run into this problem I'd appreciate a pointer or two - been on this now of the last week with no results


  • What user is the SQL Server and SSRS server themselves logging into the machine as? If you open the services applet in control panel the last column is "Log On As", I willing to bet one or both of them is that user..


  • Hi Elliot

    thanks for reply - apologies I haven't replied. Busy on other problems.

    I checked the runas account for the SQL Server and Reporting Services

    SQL Server is running as the Network Service, Reporting Server as local admin - we did make some changes to try and get things work - if not right at least workinjg so we knew where the problems were.

    I have added NT Authority\Network Service to the msdb, reportserver, database in question with sysadmin, and rsexec permissions.

    I have made sure that the folder MSRS10 has the above account with full privs - still no luck.

    I do not have any security failures on the event logs.

    I have also added the Network Service account to report server with Browser and Content Manager privs.

    So from elimination it is the SQL Server that is having the problem - but what is the problem? This is what I cannot determine hence finding it hard to correctly fix - at the moment I using a scatter gun approach but missing!


  • I can guide you..

    Create a domain user (if the server is a member of a domain, if not a local user), this user doesn't need any special permissions yet.

    Perform the procedure at:

    You need to have SQL loggin in as a USER, not as the network service. This should handle your problem.


  • thanks Elliot - I'll give this a go and let you know.

    Would it be better to also have the RS service account run as the same user?

  • nope - this is just not happening.

    I created a new domain account - ordinary user.

    Using KB doc I changed the account SQL Server logs in as - to above user.

    I add user to SQL Server and give it sysadmin privs

    I add it to the database and reportserver dbs with public and rsexec permissions

    I add the user to reporting services - via http://localhost/reports/ --Properties wth browse permissions - error below

    except=System.Web.Services.Protocols.SoapException: The permissions granted to user 'DOMAIN\SQLService' are insufficient for performing this operation. ---> Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions grante

    d to user 'DOMAIN\SQLService' are insufficient for performing this operation.

    at Microsoft.ReportingServices.WebServer.ReportingService2005Impl.FireEvent(String EventType, String EventData)

    at Microsoft.ReportingServices.WebServer.ReportingService2005.FireEvent(String EventType, String EventData)

  • I have been doing some research for you on this and have some things for you to think about..

    1. Are you sure that IIS virtual directory ReportServer security tab has Integrated Windows Authentification selected ?

    2. Not sure about this one..

    3. Even though this references sharepoint, I think it might apply..


Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply