Unable to start execution of step 1

  • I'm trying to create a backup plan and when I run it, I get the error:

    "Unable to start execution of step 1 (reason: line(1): Syntax error). The step failed."

    This is a simple backup database to file every tuesday and thursday plan. Using sa authentication.

    Anyone have an idea?

  • Line 1:

    EXECUTE master.dbo.xp_create_subdir N'C:\SQL Server Backups\test'

    If I run the t-sql manually it works (From New Query).

  • Also note, this is running on vmware, so I don't know if this would affect it.

  • I tried configuring the user for sql service service and sql server agent service as administrator but still not working.

    I have this procedure working on my physical machine.

  • Problem fixed by applying SP2.

  • SP2 is already installed and in my case the problem occurred 'out of the blue'.

  • Try this:

    1. Go to SQL Server Agents\Jobs. Select job and click Properties.

    2. Go down to Steps

    3. Highlight your SubPlan and click Edit

    4. Add a Backslash to the beginning of the path listed in the "Package" box

    Thanks,

    Rupashri

  • Thanks Rupashri this worked for me.

    This was driving me mad :w00t:

  • Hi,

    I had exactly the same problem - this just started occurring for no real reason. I added the \ to the start of the package as suggested and it has fixed the problem - many thanks !

    My question though is - do you know why this has occurred - and how adding the \ has managed to fix the problem ?

    Thanks once again.

  • Hi,

    Please let me know,how adding the \ Backslash to the beginning of the path listed in the "Package" box is fixing the issue.

    Thanks,

    Deepak

  • Thanks its working!!!!!

  • This post was very helpful for me as well, thanks very much for posting this solution !!

    FYI - Am using SQL 2005 base ver. 9.0.1399

  • Yet another reason I like this site. Worked for me also!!!

  • Hi, I applied the same method of adding a backslash on the path and it worked when i ran it manually...it was suppose to run at 12am as scheduled the following morning but it failed, what could be the problem?

  • Thanks for this, working great for me.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic. Login to reply