Unable to load the Vertipaq Engine

  • Eric Mamet

    SSChampion

    Points: 11552

    I was looking forward to play with this (new) toy but can't get anything working...

    I have installed

    - Office 2010 with Excel 32 bits

    - Sql Server 2008 R2

    - PowerPivot 10.50.2500.0 (the one coming with 2008R2 I think)

    - Sql Denali ctp3

    When I try to open the "PowerPivot Window" on a brand new spreadsheet, I get various error messages:

    - Embedded Analysis Services Engine: Could not open embedded PowerPivot data. (twice)

    - Then an option to "Do Nothing" or "remove the PowerPivot data"

    Finally, I get an error message "Unable to load the Vertipaq Engine".

    Any idea what I could do to fix this?

    Should I install PowerPivot from Denali CTP3 instead of 2008R2?

    I have already tried

    - uninstal PowerPivot

    - reboot

    - re-install PowerPivot

    But no joy so far...

    Any idea welcome! 🙂

  • Koen Verbeeck

    SSC Guru

    Points: 258909

    The PowerPivot that comes off the SQL Server installation media is intended for integration with SharePoint. For Excel itself (locally on your desktop), you need to download a plug-in from www.powerpivot.com. Did you do this?

    Make sure you download and install the 32-bit plug-in, as you have Office 32-bit. Even if you have a 64-bit OS!

    Need an answer? No, you need a question
    My blog at https://sqlkover.com.
    MCSE Business Intelligence - Microsoft Data Platform MVP

  • Derek Markel

    SSC Enthusiast

    Points: 174

    Try installing the Denali version of PowerPivot. After installing SQL Server Denali CTP3 on my PC I also received this error when trying to use the SQL 2008 R2 version of PowerPivot.

    http://www.microsoft.com/download/en/details.aspx?id=26721

  • Eric Mamet

    SSChampion

    Points: 11552

    Yes, I installed the 32 bits version

  • Eric Mamet

    SSChampion

    Points: 11552

    Thanks Derek, I'll try that as soon as I get a minute.

    Seems to make sense

  • Eric Mamet

    SSChampion

    Points: 11552

    Marvellous!

    It worked. Many thanks

    😀

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic. Login to reply