Unable to connect to named instance.

  • There is a server running SQL Server 2012 32 bit. This is the default instance. We can connect to this remotely.

    We installed sql server 2017 standard edition as new instance (64 bit) and named it as Dev2017

    Issue :- I am able to connect to the named instance from within the server but not from outside.

    Additional info :-

    Remote connection is enabled.

    SQL Browser service is up and running. TCP/IP and named pipes are both enabled for the new instance.

    Port 1434 is open in the firewall.

    When i connect the named instance from my local machine (pointing to the server), i get this error.

    TITLE: Connect to Server


    Cannot connect to XX.XX.XX.XX\dev2017.



    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) (Microsoft SQL Server, Error: -1)

    For help, click: https://docs.microsoft.com/sql/relational-databases/errors-events/mssqlserver--1-database-engine-error

    I have no clue on how to proceed on this as I followed general guidelines. The only thing i can think of is that sql browser service is still old (2012 32 bit). Do I need to replace it with 2017 to fix this? If yes can someone help me with correct steps? Or can there be other issues that I am not seeing.

    Any help will be appreciated.

    Pradeep Singh

  • Couple things. Is port 1434 opened for UDP or TCP? The former is needed.


    If you get the port for the named instance, can you connect remotely? This is in the log when the instance starts.

  • Thanks Steve.

    TCP port was enabled. I added rule for UDP 1434 and it worked like a charm.

    Thank you!

    Pradeep Singh

  • happy to help. A common mistake that people make.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply