Unable to change default Date format in SQL Server Express

  • User_from_Europe

    Grasshopper

    Points: 20

    I have a problem with changing default Date format. I changed the language to British English on server. I added new user and set British English as default language for him, but date is still showing in format ymd.

    I want all dates in all databases to be in format dmy as default. I have tried this both on SQL Server Express 2014 edition and 2016 edition, but all dates are still in old English format (ymd).

  • Thom A

    SSC Guru

    Points: 98029

    You don't need to change the format of your dates in your SQL, change it in your presentation layer. SQL will always display dates in the format yyyy-MM-dd, as per msdn, it's not relevant to your language settings.

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic. Login to reply