Unable to access Reporting services reports from application

  • sram24_mca

    SSCrazy

    Points: 2614

    We have configured the reporting services to view the application reports. Report server is hosted in one system and application is hosted on other system (Not in Domain Group). When we access the reporting services - Reports we are getting the error messages says - Http 401 Unauthorized....!

    Please suggest what might be wrong...

    Regards,
    Ram

  • Thom A

    SSC Guru

    Points: 98211

    The error message is giving you the answer here, access is not authorised.

    As tThe Computer is outside of the domain and it more than likely does not have access to SSRS. If the other domain is part of the same forest, you'll need to allow the domain SSRS is on to be able to trust the other domain, and then add the users(s) or group(s) of the other domain permissions to do whatever they need on SSRS.

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • sram24_mca

    SSCrazy

    Points: 2614

    Both the systems are in WORKGOUP domain..!

  • Thom A

    SSC Guru

    Points: 98211

    sram24_mca - Wednesday, October 11, 2017 3:25 AM

    Both the systems are in WORKGOUP domain..!

    Are you using a domain called WORKGROUP, or do you mean they both PC's are in the Workgroup WORKGROUP?

    If the latter, I've had no experience with using SSRS using Workgroups. You should, however, still be able to add the users of the other PC to the permissions; you'll just need to specify the PC name as part of the username. For example PCName\Thom rather than just Thom. You'll need to add their permissions first by connecting locally.

    Edit: Ok, seems, after a quick Google (a wondering tool, you should try it 😉 ) that you can't authenticate via a Workgroup. You'll need to disable anonymous authentication on IIS, and then any users accessing the SSRS instance from a different machine will need to use credentials of a User on the Machine SSRS is hosted.

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • sram24_mca

    SSCrazy

    Points: 2614

    Not a domain it's just a workgroup I have tried adding the Computername\Username and it says The user or groupname is not recognized..!

  • sram24_mca

    SSCrazy

    Points: 2614

    we are using reporting services in a application. means - we have added the Reporting services URL in App - Web.config file. In that scenario how to provide the local user credentials

  • Thom A

    SSC Guru

    Points: 98211

    sram24_mca - Wednesday, October 11, 2017 4:11 AM

    we are using reporting services in a application. means - we have added the Reporting services URL in App - Web.config file. In that scenario how to provide the local user credentials

    I'm not sure you can.

    I had a Google (selling that search engine again) and found a few ideas, but with no environment to test, I can't give an answer. One such, I saw, was having the users on both machines.

    Someone else might be able to give you a solution here, but unfortunately, I don't have enough understanding or knowledge for a non-domain set-up.

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • sram24_mca

    SSCrazy

    Points: 2614

    Thanks Thom..!

  • sram24_mca

    SSCrazy

    Points: 2614

    Any Answers for my Query

  • Sue_H

    SSC Guru

    Points: 89885

    sram24_mca - Wednesday, October 11, 2017 11:25 PM

    Any Answers for my Query

    Thom did answer you. The logins would need to authenticate on the local server since it's a workgroup and there is no domain to authenticate against.
    The workaround for that is to have the same logins, passwords on the Reporting Services machine. If that doesn't work, you would need to use custom security extensions - something like forms authentication which I personally think is a nightmare.

    Sue

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic. Login to reply