Transparent Background Color in SSRS Textbox

  • pollyjeanherr

    SSC Veteran

    Points: 276

    I get a warning similar to this:

    [rsInvalidColor] The value of the BackgroundColor property for the textbox ‘textbox22’ is “Transparent”, which is not a valid BackgroundColor.

    every time I use "Transparent" as a color in the conditional expression for BackgroundColor.

    Why does this happen? The reports seem to work regardless. In newer reports I am using "White" in similar circumstances, but since "Transparent" is the default BackgroundColor why does it generate an error?

  • w.plymesser

    Old Hand

    Points: 370

    I know this post is over a year old, but the same error has got me puzzled.

    I'm using SSRS 2008.

    I also get this error when using "No Color" in a conditional expression. That's what the property value is set to when first opened. I've got two textboxes, and I set each one to use each (non)color.

    [rsInvalidColor] The value of the BackgroundColor property for the text box ‘Textbox57’ is “No Color”, which is not a valid BackgroundColor.

    [rsInvalidColor] The value of the BackgroundColor property for the text box ‘Textbox58’ is “Transparent”, which is not a valid BackgroundColor.

    Here's the expression I'm using:

    =iif(Parameters!RptGrouping.Value="Region",iif(Fields!Grp1.Value<>" ","Transparent","LightGrey"),"Transparent")

    Basically, if the report is at a Regional level, I want to color the text box Light Grey if the Grp1 field is populated. It works, even with the error. Is this one of those times where I ignore it and move on?

  • w.plymesser

    Old Hand

    Points: 370

    :ermm: I changed one little search parameter after posting the problem, and found the answer.

    Instead of "No Color" or "Transparent", I used "#FFFFFF", and it works flawlessly.

    Found at http://www.johnstagich.com/Blog/post/September-2010-Quick-Hits.aspx.

  • mark 4643

    SSCommitted

    Points: 1503

    w.plymesser (1/11/2012)


    :ermm: I changed one little search parameter after posting the problem, and found the answer.

    Instead of "No Color" or "Transparent", I used "#FFFFFF", and it works flawlessly.

    Found at http://www.johnstagich.com/Blog/post/September-2010-Quick-Hits.aspx.

    of couse it does FFFFFF is white. That is NOT transparent

  • Oliiii

    SSCertifiable

    Points: 5328

    Set the color to Nothing and it works:

    =Iif(Fields!InstanceBlackout.Value = 1, "Orange", Nothing)

    Found the answer here.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply