The user name or password is incorrect-Log on failed. Ensure the user name and password are correct. &The remote server returned an error: (500) Internal Server Error.

  • rezmes

    SSC Veteran

    Points: 280

    Hi every one,

    Situation:

    1. Windows 2008 R2 Data Center Edition > Data Base Server

    – Microsoft SQL 2008 R2 RTM > Data Base

    2. Windows 2008 R2 Enterprise > WFE

    – SharePoint 2010 Enterprise

    – PowerPivot for SharePoint

    – SQL Server Integrity Services

    – SQL Reporting Services

    – Excel Services

    – Visio Services

    – …

    Error:

    – The user name or password is incorrect-Log on failed. Ensure the user name and password are correct.

    – The remote server returned an error: (500) Internal Server Error.

    Elaboration:

    When I create a direct and individual .rdl files, They are running properly and there is not problem.

    The problem occurred when I clicked on "create report builder report" in a Gallery view where I uploaded a .xlsx enriched by PowerPivot to make a .rdl report.

    When the "sql server 2008 r2 report builder 3" ran, the data source was created automatically like this:

    Data Source=http://<domain name>/sites/<site collection>/Gallery1/<file name>.xlsx

    point one:

    The credential was set:

    "use current windows user. Kerberos delegation might be required."

    and in General> test connection > Connection Created Successfully

    But:

    In Datasets (right click)> "Add Dataset…" > use a dataset embedded in my report, <file name>.xlsx, Query Designer…

    The error occurs here: "The remote server returned an error: (500) Internal Server Error."

    Point two:

    Change the credential of data source to:

    "use this user name and password:

    User name: <domain>\<user>

    Password: ****

    Use as windows credential

    But:

    In Datasets (right click)> "Add Dataset…" > use a dataset embedded in my report, <file name>.xlsx, Query Designer…

    The error occurs here: "The user name or password is incorrect-Log on failed. Ensure the user name and password are correct. "

    P.S:

    I test these:

    On WFE > reporting services configuration manager>

    Ø <domain>\reporting services > Start Services

    Ø Service account > use another account <user name> and <password>

    Ø …

    Ø Execution account > "specified"

    Ø Encrypted key deleted

    The SSIS is running in both server (PowerPivot for SharePoint which is on WFE and SQL server)

    - I checked all possible position (stop it on one of servers and start on another…)

    I disable the anonymous Access in Central Administration > Authentication Provider> Edit default Authentication> remove tick mark (and one another time put it)

    Plus both Enable and disable client integration

    I checked log file in

    %program file%\ Microsoft SQL Server\MSRS10_50.REPORTINGSERVICE\Reporting Services\LogFiles

    There was no recent log file (the last one was for about 5 hours ago), besides there was nothing corresponding with these errors.

    … if there is anything that I didn't explained, please ask me.

    I am straggling with this error about 12 days.

  • rezmes

    SSC Veteran

    Points: 280

    more details

    - System

    - Provider

    [ Name] Microsoft-Windows-Security-Auditing

    [ Guid] {54849625-5478-4994-A5BA-3E3B0328C30D}

    EventID 4625

    Version 0

    Level 0

    Task 12544

    Opcode 0

    Keywords 0x8010000000000000

    - TimeCreated

    [ SystemTime] 2015-09-23T13:15:03.455052000Z

    EventRecordID 428314

    Correlation

    - Execution

    [ ProcessID] 632

    [ ThreadID] 5260

    Channel Security

    Computer Evalsys.sked.org

    Security

    - EventData

    SubjectUserSid S-1-0-0

    SubjectUserName -

    SubjectDomainName -

    SubjectLogonId 0x0

    TargetUserSid S-1-0-0

    TargetUserName sked\spadmin

    TargetDomainName

    Status 0xc000006d

    FailureReason %%2313

    SubStatus 0xc0000064

    LogonType 3

    LogonProcessName NtLmSsp

    AuthenticationPackageName NTLM

    WorkstationName VISTARAYAN

    TransmittedServices -

    LmPackageName -

    KeyLength 0

    ProcessId 0x0

    ProcessName -

    IpAddress 10.180.129.1

    IpPort 61789

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic. Login to reply