The transaction log for database 'tempdb' is full due to 'NOTHING' (during cluster install)

  • caddywonkus

    Right there with Babe

    Points: 763

    I'm wondering if anyone has seen this rather peculiar error while installing SQL 2012 on a cluster before, specifically if putting tempdb on the local disks during setup.

    There's no serious urgency on my end, I'm literally messing around with the cluster installation on a test cluster exactly for this reason - to learn about any new good-to-know gotchas before I do the real thing. Already found a couple minor things (like the cluster machine account needs "Create Computer Object" on the pre-staged computer account's OU ... not just full control on the account itself, which used to be good enough in 2008).

    This one has me a tad stumped though; during the "Advanced cluster completion" phase (both nodes were already prepared successfully, with no issues):

    The transaction log for database 'tempdb' is full due to 'NOTHING'

    Never mind it being at least a candidate for a "best errors" list...

    Again this is during installation, there is no actively running instance involved. I'm installing a clustered SQL, default instance, with tempdb on the local disks. It's not the usual "log full" for a good reason; the instance isn't even fully installed yet. It's not disk space; both nodes have 20+ GB free on the path I'm putting it in. It's not a mistyped path or permissions; SQL setup clearly found it and was able to work with it, at least at some point, because the MSSQLSERVER service account (NT SERVICE\MSSQLSERVER) was added to the folder's ACL - with Full Control no less - and I didn't do it. There are no tempdb files (or anything else) in it though. There's nothing special about the folder at all; it's just an ordinary subfolder I created, C:\TEMPDB. It's not even a mounted volume (on the real cluster the intent is to put tempdb on lettered, local SSD drives).

    I'll keep poking at it, but meanwhile if anyone has already encountered this and knows what particular weirdness I've run into here... please let me know. I know in principle it works - I've already tested installing on a cluster a couple times before, including with tempdb on the C:\ drives of the nodes. But something strange happened here, and I'd really like to know what in case I run into it again.

  • shmunks

    SSC Journeyman

    Points: 80

    I got the same error message a few times today and it makes no sense. I got mine while completing a prepared instance, though.

    I'm going to try granting Full Control to Everyone on the drive where I want to put TempDB and see if that makes a difference...

    By any chance, is it a VM you're installing to? And if so, is the C: a fixed size or 'dynamically expanding'?

  • shmunks

    SSC Journeyman

    Points: 80

    Ok, this time it worked. Changes I made:

    1. Granted Full Control to Everyone on the T: drive

    2. Changed the name of the folder from T:\TempDB to T:\SQLTemp

    3. Set the VHD type to Fixed instead of Dynamically Expanding

    One of those (or the alignment of planets or something) made it work...

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply