The Service Broker protocol transport is disabled or not configured.

  • Hi all,

    I want to handle "The SQL Server Service Broker or Database Mirroring transport is disabled or not configured" error via SCOM but i do not have any knowledge about end points and Is there any shortcut about endpoint definition in system databases?

  • Googling helps:

    To determine whether or not Service Broker is enabled for a particular database, execute the following T-SQL:

    SELECT is_broker_enabled FROM sys.databases WHERE name = 'Database name';

    -- Enable Service Broker:


    -- Disable Service Broker:


    Database Mirroring is enabled after install Service Pack 1 or later.


  • I have searched on this quite a bit and keep finding the simple answer of turn it off. I get that but my question is why is it on in SP1 and what is the reason to have it on vs off?

    In this case making the Ops Mgr alert go away is not what I'm interested in but why its on in the first place.

    Or put another way what am I going to break when I turn it off on 30 of my databases?

  • We are getting this SCOM alert at reboot time. Not sure if the answer is to disable the alert or to change something on the server.

  • Keep in mind there is more to service broker than meets the eye !

    First read a bit about it, so you know what it is all about and you know how to troubleshoot it.

    There are a number of article at SSC.

    SQL2005 has been released with SSB still in CTP mode (beta) !

    This has been announced and SP1 has been released pretty soon after RTM.

    anyway .... Your instance(s) should be on SP3 by now.

    SCOM probably comes with some prereqs and they may even state some SP of HF level of SQL2005.


    Learn to play, play to learn !

    Dont drive faster than your guardian angel can fly ...
    but keeping both feet on the ground wont get you anywhere :w00t:

    - How to post Performance Problems
    - How to post data/code to get the best help[/url]

    - How to prevent a sore throat after hours of presenting ppt

    press F1 for solution, press shift+F1 for urgent solution 😀

    Need a bit of Powershell? How about this

    Who am I ? Sometimes this is me but most of the time this is me

  • I had the same alert in SCOM for some time.

    You need to configure both service broker and database mirroring if you don't want this alert to occur repeatedly.

    Since I don't need database mirroring on our databases I decided to disable this alert on SCOM.

Viewing 6 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply