Strange Linked server issue

  • l.madhupradeep

    Old Hand

    Points: 372

    Hi All,

    I am having problem with pulling data from Linked Server that I have created using "Oracle Oledb Provider". I am able to created Linked server and tested the connection successfully. But I am unable select the data from table when running SELECT statement. I have used both four part naming and OPENQUERY method. I am getting same error in both cases.

    Here is the error I am getting.

    Msg 7399, Level 16, State 1, Line 1

    The OLE DB provider "OraOLEDB.Oracle" for linked server "IMPRX_D" reported an error. The provider did not give any information about the error.

    Msg 7330, Level 16, State 2, Line 1

    Cannot fetch a row from OLE DB provider "OraOLEDB.Oracle" for linked server "IMPRX_D".

    Environment:

    SQL Server 2005 SP3 32-Bit

    Windows 2008 R2 64 Bit

    Oracle 11g Client 64 bit

    Please let me know if I missed to provide any details.

    Thanks

    Madhu Pradeep

  • l.madhupradeep

    Old Hand

    Points: 372

    All,

    I have fixed it using "Allow in Process" Setting of "Oracle.oledb" provider.

    1. Unchecked "Allow In Process" setting for provider.

    2. Created Linked Server.

    3. Checked "Allow In process" setting for provider.

    I could n't created Linked server when above setting is enabled, So I had to uncheck the option and create the linked server.

    But I don't really understand why.

    If anyone has same experience and know the reason, Please post here.

    Thanks

    Madhu Pradeep

  • Student Online

    SSC Enthusiast

    Points: 104

    Hi,

    I had the same error message popping up after a few rows being retrieved from the linked server. The same query when ran on a different data set, was working fine without any errors. Then I started some research and came to know that, it was a data related issue.

    In my scenario, the select statement was having a case condition which was failing to validate.

    Thanks

    Kranthi

  • mette.evert

    SSC Veteran

    Points: 225

    Hello,

    I had the same error, and it was solved using your advice, thank you for that.

    Though: The parameter "Allow In Process" was unchecked after installation. The creation of the linked server worked, but queries using the linked server failed. I dropped the linked server, marked active the "Allow In Process", recreated the linked server and after that, the Query succeeded. Weekend saved 🙂

    Regards, Anne Evert-Nielsen

  • mette.evert

    SSC Veteran

    Points: 225

    Failed to find the reason, it is to be investigated...

  • Jeronimo13

    SSC Enthusiast

    Points: 165

    I've got the same problem here.

    I dropped the linked server

    Unchecked the Allow inprocess option.

    Recreated the linked server by using query

    Checked the Allow Inprocess option

    Tested the query that failed at first time.

    Result was not what I needed. So no help for me sofar.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic. Login to reply