Stairway to SQL Server Extended Events Level 2: Creating Basic Event Sessions in the UI

  • Erin Stellato

    Ten Centuries

    Points: 1176

    Comments posted to this topic are about the item Stairway to SQL Server Extended Events Level 2: Creating Basic Event Sessions in the UI

  • Alessandro Mortola

    Say Hey Kid

    Points: 676

    Great job Erin, I'm looking forward to read next levels

  • james.jensen1350

    Say Hey Kid

    Points: 700

    Great article and many thanks for describing this feature.

    I followed the example, creating a new Session with the parameters you defined and so forth, but I cannot view it live. I get an SSMS error box that states "The storage failed to initialize using the provided parameters. The Extended Events session named "HighReadQueries" could not be found. Make sure the session exists and is started. (Microsoft SQL Server, Error: 25728)"

    According to what I discovered in a quick Google search was that no one seems to have encountered this problem. 😀 Natch.

    So, I opened the tree under HighReadQueries, right-clicked on the file ("package0.event_file" in my case), selected View Target Data, and got a different error: " Cannot view the function "fn_MSXe_read_event_stream", because it does not exist or you do not have permission. (Microsoft SQL Server, Error: 15151)"

    Because I am working with the 2014 version of SSMS and SQL Server, I can only assume that I have to rectify a permissions issue. Have you run across this kind of a problem before? If I get it solved, I will post the resolution here, but that may not happen for a while since there is no current business need to spend a lot of time on this.

  • Erin Stellato

    Ten Centuries

    Points: 1176

    Hi James-

    What permissions do you have on the server? You need ALTER ANY EVENT SESSION in order to create and view sessions. And what specific build of SQL Server 2014 are you running? Thanks,

    Erin

  • james.jensen1350

    Say Hey Kid

    Points: 700

    Well, I do *not* have any ALTER_ANY_EVENT_* permissions granted. The server version is:

    Microsoft SQL Server 2014 - 12.0.4213.0 (X64)

    Jun 9 2015 12:06:16

    Copyright (c) Microsoft Corporation

    Enterprise Edition: Core-based Licensing (64-bit) on Windows NT 6.3 <X64> (Build 9600: ) (Hypervisor)

    Edit:

    FWIW, I granted myself ALTER_ANY_EVENT_SESSION permissions, but it changed nothing.

    I *tried* to grant myself permissions, but it did not take. I must speak with the higher powers about this before trying again.

  • akljfhnlaflkj

    SSC Guru

    Points: 76202

    Great article, thanks.

  • Jefferson Elias

    Ten Centuries

    Points: 1379

    Great article. Looking forwards to the next stair level 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply