SSRS Report Data Source Error with TLS 1.2

  • Ghamzi

    SSC Veteran

    Points: 265

    As part of the PCI initiative to disable weak ciphers, we began that process at my company. After following all the recommendation mentioned in KB3135244 and this MSDN blog post, we rolled out few development servers running with TLS 1.0 disabled.

    Server A: Running SQL Server & SSRS running SQL Server 2012 SP1 (11.0.5058). Installed .NET Framework 4.6.1, SNAC 11.0.6518 (TLS 1.2 Capable)

    Server B: Running SQL Server 2014 SP1 CU5 (12.00.4439). TLS 1.0 is disabled.

    We are able to connect to Server B locally, and remotely from Server A using SSMS, SQL Data Tools, and even SQL Server Report Builder. The data source can be tested in any SSRS design tools without any issues. However, once deployed and ran through the SSRS webpage or through a subscription, we receive the following error:

    A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: TCP Provider, error: 0 - An existing connection was forcibly closed by the remote host.)

    Creating a data source via the web page result in the same error. Windows Authentication or SQL Server Authentication makes no difference. Any one has any similar issues?

    Has anyone been able to run reports against SQL Servers that has TLS 1.0 disabled?

  • Ghamzi

    SSC Veteran

    Points: 265

    Anyone got any idea?

  • Jo Pattyn

    SSC-Dedicated

    Points: 31273

  • shamshad.ali

    Hall of Fame

    Points: 3850

    I am facing same issue and have installed SQL Server 2012 SP4, both the report server A and database Server B have same installation and SP versions, but reports do not run giving same error mentioned earlier in this question.
    Please guide.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply