SSRS And Inconsistent Kerberos Authentication

  • Guðjón Kr. Sigurðsson

    SSChasing Mays

    Points: 609

    Hi,

    I'm having problems with Double Hop Scenario With Kerberos Authentication.

    IE On Windows Clients -> MSSQL Report Server -> MSSQL Database Servers (misc mssql hosts with misc source systems/databases being reported from)

    Help would be greatly appreciated.

    Problem description

    Users running reports occasionally (very inconsistent and no apparent patterns) receive the following error message after executing SSRS reports with Windows Integrated Security:

    "An error has occurred during report processing. (rsProcessingAborted)

    Cannot create a connection to data source 'dsDW'. (rsErrorOpeningConnection)

    Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'."

    And ofcourse the report execution fails with that.

    This "situation", where the user can not execute his/her reports, will be existent for undetermined time period.

    Let's say later in the evening the user tries to run the report again and then everything is working like a charm.

    Quite naturally the user asks himself what tomorrow brings.

    It is to say the least very unfortunate that the users no longer can rely on access to their reports.

    For them it is the daily lottery.

    Suspected cause of the sudden disruption

    Domain controller upgrade activities around the same time the reports enter the inconsistent state.

    A 2008 Domain Controller Cluster was added to our existing single 2003 Domain Controller.

    The 2008 ones were made default.

    The above mentioned situation applies to both my test and prod identical SSRS instances installed on seperate hosts.

    Instances that used to be perfectly in good shape (no auth errors nada).

    SSRS Config

    <AuthenticationTypes>

    <RSWindowsNegotiate />

    </AuthenticationTypes>

    SPN Setup (for the domain account running the SSRS)

    HTTP/ReportManagerTest

    HTTP/ReportManagerTest.domain.is:8080

    HTTP/ReportManagerTest:8080

    HTTP/l77-ssis-d1:8080

    http/l77-ssis-d1.domain.is

    http/l77-ssis-d1.domain.is:8080

    http/l77-ssis-d1

    In the active directory the same domain account has the following delegation permissons:

    Trust this user for delegation to any service (Kerberos Only)

    SPN Setup (for the domain account running the database engine service from where the report is reading data from)

    MSSQLSvc/s1-sqlacq-p1:1433

    MSSQLSvc/s1-sqlacq-p1.domain.is:1433

    SSRS Host Versions

    Microsoft SQL Server 2008 R2 (SP1) - 10.50.2500.0 (X64) Jun 17 2011 00:54:03

    Copyright (c) Microsoft Corporation Developer Edition (64-bit) on Windows NT 5.2 <X64>

    (Build 3790: Service Pack 2) (Hypervisor)

    Database Service Host Versions From The Above Example

    Microsoft SQL Server 2008 R2 (RTM) - 10.50.1600.1 (X64) Apr 2 2010 15:48:46

    Copyright (c) Microsoft Corporation Enterprise Edition (64-bit) on Windows NT 6.1 <X64>

    (Build 7600: ) (Hypervisor)

    Thanks in advance,

    Gudjon

  • wayne.yan

    SSC Rookie

    Points: 41

    We had same issue. Resolved it to the SQL server having problems with DHCP. Added static DNS A record and all was fixed.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic. Login to reply