SSRS 05 subreport issues

  • So I've got a report consumer who needs about 20 different reports combined into 1 big one so that they can do some auto pagination and such when they compile these reports as a monthly report. they'd like to then only have to change the source reports instead of having 1 big report to change and then the little ones to change as well...

    I've been able to add most of the reports a subreports that way the parameters get passed the same way to all of the reports and it pages correctly. I've added each sub report inside it's own rectangle so that I can do some manual page breaks and such.

    the problem I am having is one Matrix report which I can't for the life of me figure out why it won't fit on a 8.5x11 in page in portrait. For some reason the dynamic abilities of the matrix seem to be throwing off my report. I've not had any of the issues with table reports that I do with the matrixes.

    The original report is set to 5.125 in wide, originally it was 6.5" wide and I've been reducing it.

    I've set the subreport size to everything from 5in to 6.75 in and the result is the same about .125in of my rectangle appears on the next page. Btw, I've tried resizing the rect. the subreport and the original report to even get it this close. Any ideas, or perhaps a better way to have all of the reports generating int he proper sequences with the appropriate page numbers would be very helpful...

    Also, the margins have totally been set to 0 at this point for both the source report and the main report, as I figured I'd be able to make use of that space, but that was proven incorrect.

    thanks in advance.

    -Luke.

    To help us help you read this[/url]For better help with performance problems please read this[/url]

  • Hi Luke...:)

    Did you try to incorporate all Sub Reports with in a List control..??

    If not...I think...try a little bit with a rectangle on a list control...It should solve this issue....for resizing of subreport (s)...

    Thanks,

    Niraj

  • I'll give it a go thanks.

    -Luke.

    To help us help you read this[/url]For better help with performance problems please read this[/url]

  • I may have attempted your solution incorrectly... I tried to include all of my subreports inside of rectangles inside of a list control, however when I run the report it seems to repeat each subreport in the list numerous times. Is there a way around this?

    Thanks.

    -Luke.

    To help us help you read this[/url]For better help with performance problems please read this[/url]

  • Hi...

    Good Morning....

    First of all...I am very sorry. to mention earlier..that after inserting sub reports in a rectangle (yes..inside a list control)...we need to form a group too...on the list control...

    So...Luke...pls make a group for any field on List Control...and it will not repeat the reports....

    Thanks....:)

    Niraj

  • I think I'm still a bit confused. I put a single list control on my report then added the sub reports contained within rectangles to the list. I added the group to remove the repeats, but it seems like I'm still having the same problem. When I did it with just 1 ractangle/subreport in a single list it worked well. Is that what you were meaning to recommend. 1 list control for each subreport inside a rectangle?

    Thanks.

    -Luke.

    To help us help you read this[/url]For better help with performance problems please read this[/url]

  • Hi Luke...

    You have done absolutely correct...There is no need to include seperate List control for every following sub reports...within a single list control only...we can perform the same operation...

    Please let me know...the sub reports which you wish to use ...they all have different parameters or atleast a common parameter...??

    If they have the same parameter...then a single List control with a group on that parameter name will definitely work...Otherwise..you can opt for multiple List controls if your sub reports use different parameters...

    Thanks..:)

    Niraj

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply