SSMS check for updates proxy server settings

  • Hi,

    1. I Googled extensively before posting - all I got were hits for SQL Agent port settings.
    2. I hope this is the correct (or at least an appropriate) forum for this question.  If not please enlighten me.

    My company has moved from ProxyServerA to ProxyServerB.

    If I do SSMS -> Tools -> Options -> Web Browser -> Internet Explorer Options -> Connections -> LAN settings ->

    (Automatically detect settings ticked + Use automatic configuration script ticked + ProxyServerA details),

    then Tools -> Check for Updates works (as well as automatic check for updates + SQL Complete check for updates)

    If I do the same thing for ProxyServerB, both fail:

    2019-08-07_11-54-00

    2019-08-07_11-55-31

    I've told my IT Department to check the configuration between old and new proxy re: port settings.  Or perhaps the new proxy isn't accepting my LAN credentials as authentication?  Although I would think "everything" would fail in that scenario?

    The weird thing (to me anyway) is that the new proxy server works in SSDT 2015/2017 and Visual Studio 2019 with respect to Check for Updates.

    If you know what needs to be configured in a proxy server for SSMS (and SQL Complete within SSMS) to check for updates, please let me know.

    Thanks...

  • Interesting. One thing, have you restarted SSMS between changing settings?

  • Thanks Steve.  Yes I have, although the changes do seem to take effect immediately.  IOW, ProxyServerA works, change to ProxyServerB, ok out of Tools..., fails, reverse this, works, all without restarting SSMS.

    I know this isn't a network configuration forum, and my IT department should figure this out eventually, but they'll have to escalate to a 3rd party external support organization, take weeks (or may just bail on the issue), etc.  I was hoping to help them out a bit, and get my problem solved quicker via this forum.

    I fully admit this isn't urgent - I can manually check for updates (i.e. Google), download the installer(s), and install manually.

    Still, it would be interesting to know why this is failing...

  • Thanks for the update, and I agree. Sounds like networking. Be interested in the solution if you find it.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply