SSIS package hangs on validation in Visual Studio

  • vipin_jha123

    Hall of Fame

    Points: 3085

    I've built an SSIS package in SSDT 2014. The package was running successfully

    when I close and open the package it hangs on validation of single task out of all.

    OLEDB DESTINATION Task

    I have tried several times to close the SSDT and open but facing same issue.

    Please help me to get rid out of above issue.

    These seems like bugs in SSIS/SSDT. What would cause the relocation of some script code to hang the validation process like this?

    Regards,

    Vipin Jha

  • Emil B

    SSCertifiable

    Points: 5568

    it might be that the oledb destination task can not connect to destination and validate it. check your oledb connection in connection manager that is being used by this task and make suere it works.

  • Bunter58

    SSC Enthusiast

    Points: 116

    I also had an edit appear to hang validating output to a Fact table. What I worked out was that at the same time, I was altering the table to grow a smallint column to an int. That's on a fact table with 7 billion rows and a clustered columnstore index so it was taking a long time.

    I killed that process and the apparent hang went away.

    This is using SQL Server 2016 and the latest release of SSDT for VS2017.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply