SSIS package development and automation with .NET"

  • Hello everyone,

    Here's my question:

    With this call dtsRuntime.Package package = app.LoadPackage(Etl_package, null, false);,

    I load the package to read all the defined components and the defined variables.

    However, for a component of the ExecutePackageTask type, I can't access the ParameterAssignments.

    When I try to read the defined ParameterAssignment in the component with a foreach loop, it is not found, although parameters are being passed.

    Can anyone give me a tip on how to read the ParameterAssignments or how to add a parameter?

    The very last solution would be to search through the XML of the DTSX package.

     

  • I've just tried this, as I have a package structured like that.

    They've certainly made it difficult! I can get to the point in debug mode where I can see a property called 'ParameterAssignments' which belongs to the package being executed.

    It is a System.__ComObject which cannot be debugged further, which I suspect is as far as you've got. Some C# trickery will probably get you further, but I don't have the knowledge/time to dig into it now.

    If you haven't even tried to resolve your issue, please don't expect the hard-working volunteers here to waste their time providing links to answers which you could easily have found yourself.

Viewing 2 posts - 1 through 1 (of 1 total)

You must be logged in to reply to this topic. Login to reply