SSAS 2012: Processing Pool Job Queue length exceeded

  • KireLaw

    SSC Rookie

    Points: 33

    Hello,

    I have an alert from SCOM.

    Alert: SSAS 2012: Processing Pool Job Queue length exceeded.

    Source: MSSQLSERVER

    Path: *server_name*

    Last modified by: System

    Last modified time: 6/11/2020 9:50:05 AM Alert description: The length of the processing pool job queue for SSAS instance MSSQLSERVER on computer *server_name* exceeds the configured threshold.

    Current Job Queue Length: 16

    I could not find anything on the web on this topic. I only realized that the length of the queue of work exceeded.

    Maybe someone knows where this queue length of jobs is configured, or something like that? Well, or assumptions about what else the alert signals, and what needs to be done?

  • Site Owners

    SSC Guru

    Points: 80375

    Thanks for posting your issue and hopefully someone will answer soon.

    This is an automated bump to increase visibility of your question.

  • KireLaw

    SSC Rookie

    Points: 33

    https://www.sqlshack.com/bi-performance-counter-processing-pool-io-job-queue-length/

    This article helps me a little.

    To disable per NUMA node thread pool behavior, change the value of PerNumaNode property to 0 - this step doesn't help me. But when I tried to change the value of PerNumaNode property twice - to 0 and back to -1, this helps me. After each value change we need restart SQL Analysis Servises Service.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply