SQL server service account lost permission on directories

  • I last week installed a SQl 2019 instance on a new server, applied the service pack. Everything looks fine. Then this week when I login to that server again I noticed all the services in the configuration manager are down,  this include database engine, SSIS, and SQL server agent. I tried to restart the services, but it gives an error. In the event viewer the error is Access denied.

    I realized this could be the service account does not have permissions any more in those SQL server related directories. So I tried to add the service account to local admin, then the services can be restarted. This is weird, for it was working last week when I finish install, but for some reason it lost the permissions.

    I ended up to uninstall SQL server and reinstall it. But I am still very curious how it happened it lost permissions for that  has never happened before.

    Any ideas?

    Thanks

    • This topic was modified 1 month, 3 weeks ago by  sqlfriend.
    • This topic was modified 1 month, 3 weeks ago by  sqlfriend.
  • Thanks for posting your issue and hopefully someone will answer soon.

    This is an automated bump to increase visibility of your question.

  • This was removed by the editor as SPAM

  • This was removed by the editor as SPAM

  • I haven't seen this, but I guess something could happen outside of SQL to do this. I'd set the service account in config manager to another account, save, then reset to this account. That should reset permissions.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply