SQL Server 2016 RC1 Polybase Error While Creating External Data Source

  • I'm trying to set up a SQL Server to Hadoop data source following the instructions at https://msdn.microsoft.com/en-us/library/mt163689.aspx but I hit a snag while creating the external data source. I'm running a VM with SQL Server 2016 RC1 on Windows 2012 R2 and using the Cloudera 5.5 QuickStart VM for my Hadoop "cluster". When I run the CREATE

    EXTERNAL DATA SOURCE command I get an error:

    Msg 102, Level 15, State 1, Line 1 Incorrect syntax near 'EXTERNAL'.

    I don't understand why I'm getting this. I copied the syntax directly from the above web page and only changed the IP addresses, ports and credential name. The database I created for this experiment is at compatibility level 130, so it should have all the new features in it.


    WITH (


    LOCATION ='hdfs://',


    CREDENTIAL = ClouderaUser1


  • Have you got the following installed?

    Oracle JRE 7 Update 51 (64bit) or higher.

    In addition as part of the SQL installation did you select PolyBase Query Service for External Data? (Feature Selection > Database Engine Services)

    I got the same error as you until I installed Oracle and the PolyBase feature.

Viewing 2 posts - 1 through 1 (of 1 total)

You must be logged in to reply to this topic. Login to reply