SQL Replication trouble

  • rslavisa

    SSC Rookie

    Points: 26

    Hi,

    I tried to add new article to already existing and working publication and replication. I create a new snapshot after that and creation went fine. Replication started and table was created on subscriber, but stay empty with following error massage:

    Error messages:
    The process could not bulk copy into table '"dbo"."Table1"'. (Source: MSSQL_REPL, Error number: MSSQL_REPL20037)
    Get help: http://help/MSSQL_REPL20037
    metadata query failed
    Invalid character value for cast specification (Source: MSSQLServer, Error number: 22018)
    Get help: http://help/22018
    Unspecified error

    Publisher/Distributor: MS SQL 2008 R2 (SP3) - 10.50.6529.0 (X64)

    Subcriber: MS SQL 2016 (SP2-CU3) (KB4458871) - 13.0.5216.0 (X64), Compatibility level 130, same collation as on Publisher

    And everything else is working fine, transactions goes from one server to another server, except that table table1, which is empty. And I tried to create snapshpot few times, with same result.

    Any suggestion?

  • Lowell

    SSC Guru

    Points: 323442

    depending on the data types being passed in the table definition itself, sometimes no more than two versions difference allowed for replication between the publisher and the subscriber.

    SQL 2008 to SQL2016 is three versions difference between publisher and subscriber.
    change the SQL2016 database to compatibility for SQL2012 and this should work.

    https://social.msdn.microsoft.com/Forums/en-US/c9b8e8af-1f0b-4439-bde8-01e689665b4f/sql-server-snapshot-replication-error-22018?forum=sqldisasterrecovery

    Lowell


    --help us help you! If you post a question, make sure you include a CREATE TABLE... statement and INSERT INTO... statement into that table to give the volunteers here representative data. with your description of the problem, we can provide a tested, verifiable solution to your question! asking the question the right way gets you a tested answer the fastest way possible!

  • This was removed by the editor as SPAM

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply