SQL Azure Reporting Automation

  • Tushar Kanti

    Ten Centuries

    Points: 1142

    Comments posted to this topic are about the item SQL Azure Reporting Automation

  • Tushar Kanti

    Ten Centuries

    Points: 1142

    Thanks a lot Chiranjib Saha Roy for helping me complete this automation.

  • William Blakey

    SSC Enthusiast

    Points: 104

    Tushar, thank you for posting this article!  Very timely for me.

     A couple of questions if you don't mind:
    1) how do you use the Credential to authenticate to the a) Azure Subscription, and b) the SQL Database?
    2) to access my resources I have to use the "RM" version of the commands such as Login-AzureRMAccount, etc.  I guess this is because I added my objects to a Resource Group.  You use command Get-AzureSqlDatabaseUsages but there is no equivalent that I can see for the "RM" version.  Any thoughts?

    Thanks again!

  • Tushar Kanti

    Ten Centuries

    Points: 1142

    William Blakey - Saturday, June 24, 2017 4:44 PM

    Tushar, thank you for posting this article!  Very timely for me.

     A couple of questions if you don't mind:
    1) how do you use the Credential to authenticate to the a) Azure Subscription, and b) the SQL Database?
    2) to access my resources I have to use the "RM" version of the commands such as Login-AzureRMAccount, etc.  I guess this is because I added my objects to a Resource Group.  You use command Get-AzureSqlDatabaseUsages but there is no equivalent that I can see for the "RM" version.  Any thoughts?

    Thanks again!

    You can check the run as credential which is provided in the example runbook. There are both the classic and RM version for authentication.
    I did not find the RM version of the commandlet. I use sql credential to login to sql. You can run a SQL query to get the usage details. I also could not find the same hence used the classic version of the run book. Hope this helps.

  • William Blakey

    SSC Enthusiast

    Points: 104

    Ah I just noticed after re-reading your post - the code sample you gave after showing how to setup the credentials starts with the $db_info line, HOWEVER further below in your Publish screenshot that $db_info is down on line 22.  Can you please update or post a Reply with lines 1 thru 21 which are obviously important to establishing the context to run this code?  I think that'll help tremendously!  Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply