SQL Agent Problem

  • Andy Warren

    SSC Guru

    Points: 119684

  • ckempste

    SSCoach

    Points: 17983

    Great article and nice fix. A nasty little error to deal with.

    Cheers

    Ck

    Chris Kempster

    http://www.chriskempster.com

    Author of "SQL Server 2k for the Oracle DBA"


    Chris Kempster
    www.chriskempster.com
    Author of "SQL Server Backup, Recovery & Troubleshooting"
    Author of "SQL Server 2k for the Oracle DBA"

  • barwickl

    SSC Veteran

    Points: 288

    I had a similar problem myself where the agent was shown as starting and wouldn't shutdown. Fortunately a reboot solved it.

    I still don't know what caused it but sounds like it could well a different message box shown by the agent which disappeared after the reboot.

    Nice article - something to think about!

  • Jonr

    SSCrazy

    Points: 2566

    Andy,

    Thank you for sharing that, most useful. Had a very similar problem with an RLL, but with Enterprise Manager/MMC on a test machine. This was very easy to pinpoint, as I caused it myself (!) whilst doing an install of a new piece of software. Problem was that the code relied on SQL-DMO, and I had inadvertently included the SQL Server 7.0 SQL-DMO library in the install package, instead of the SQL Server 2000 DMO library. D'oh.

    The installer I was using was InstallShield (no reflection on the product, I think it's great), though accidentally picking the wrong library is I guess something you could easily do with any vendor's installation package. Did exactly the same to fix it as yourself, copied across the RLL from another box and it worked fine. Re-installed the package again and it broke it, so I knew for certain it was the culprit. Re-built the package with the SQL Server 2000 SQL-DMO and re-installed it again, worked this time, no issues. I'd suggest you install the same package you've had problems with on a test box with the same NT/SQL Server version/service pack, and see if it breaks that. Bet it will 🙂

    Looks like the problem you've experienced is with a local language resource file for the ActiveX Scripting Host, guess the package that you installed was doing something related to DTS ? If so, check out :

    http://sqldts.com/default.aspx?6,105,225,0,1

    and

    http://www.linxent.com/articles/DTS%20Package%20Files%20Needed%20for%20VB.htm

    There's also a useful note from Microsoft concerning Axscphst.dll which may impact the .rll at

    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dtssql/dts_addf_ax_06er.asp

    (note that there's an error in the regsvr32.exe example they give, end of line should read Binn\axscphst.dll...)

    Probably an incompatibility between the version of the DTS lib. you're installing from the install package, and the one on the target box that's caused the problems. These problems can be really juicy and very time consuming if you're developing for a large combination of target NT/SQL/service pack environments.

    As an aside, I love VMWare (www.vmware.com) as it means that new packages can be tested easily, and the original machine image can be 'rolled back' to an operational state if there are any problems - very cool, saves huge amounts of time, especially if you do any SQL Server related development. Recommended.

    Edited by - jonreade on 07/09/2003 02:00:00 AM


    Jon

  • David.Poole

    SSC Guru

    Points: 75363

    I've had this sort of problem with a number of applications. Message boxes that appear behind modal forms are a good one!

    I've also seen it happen when someone has converted an old VB program into a DLL but forgot to take out the error trapping message boxes.

    You can also get a problem when a Windows app bombs out and locks a file. In this scenario it is always a good idea to look at Task Manager and see what is going on.

  • tcook

    Old Hand

    Points: 314

    I have a similar problem as I changed the pw for the user running the sqlagent service (our network admin left the organization so we had to change the pw's for all domain admin. users) and the service states that it is starting....

    I tried starting the sqlagent from the command prompt and get no return and a blank .txt file as output. Nothing in the application log of the event viewer or the SQLAGENT.OUT.

    I believe this is related to the mail profile for the user because when I log on to the server as the user who runs the sqlagent service and launch Outlook it hangs as well. Trying to stop the SQL mail service in MMC also hangs.

    Any other suggestions?

    This is a production server so I can't boot during business hours.

    Thanks.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic. Login to reply