SQL 2005 SP3 Upgrade problem

  • I am fairly new to SQL and I upgrading my servers to SP3 I went to upgrade my SQL 2005 Active/Passive cluster. I did all of my backups and rebooted my servers to do a clean install. I ran the upgrade on the Active node and the install was successful. At the end it told me a few processes were locked and a reboot was required. After the reboot, I failed the node back to the original active server and checked the event logs and all was good. The issue I have is, when I fail over to the passive node I show in SSMS that SP3 is still not installed but on the original server it shows as complete. Not sure where to proceed from here. Any help would be greately appreciated.

  • You need to patch the client tools on the other node. When you run SP3, it patches the database engine and the client tools on the node that you run it from. It doesn't patch the client tools on the other node and that's why you're seeing the difference. So run the SP3 install on the other node and make sure you only select to patch the client tools / workstation components. HTH

  • I apologize I did not include this in my original post. I did fail the cluster over and ran SP3 to upgrade everthing else on the passive node. I selected all components but the databases and it did run fine as well. I rebooted both servers for good measure and still had the same result.

  • Ok, it looks like I need more information to assist with this. What clustering solution are you using? In Windows clustering, patching the database instance should patch all of the cluster nodes but in the past, I've worked with Veritas clusters where I had to patch both nodes of the cluster manually. And to do that, I had to patch the first node, fail over, restore some key files and directories, and re-run the SP3 install on the second node.

    When you run SELECT @@VERSION from each node, do you get a different result returned? I'm trying to make sure it's the database instance that's returning the unpatched release and not just SSMS. Are you using SSMS on your desktop or on the actual servers?

  • I am running a Microsoft SQL Cluster.

    Serer 2003 X-64 Enterprise SP2 R2

    SQL 2005 64 bit

    I can run the query tonight when the users are off and post the results. I did not run a query last night I relied on what SSMS was telling me .

    I ran the SSMS from each server last night when it was the active node.

    I logged into server 1 and the SSMS showed server 1 at SP3 when it was the active node.

    I failed the cluster over to server2 logged in, and SSMS showed server2 at SP2 .

    If SSMS is returning the wrong pathc level how can it be corrected?

  • I have checked the version on each serve by running Select @@version.

    Server 1 returned Microsoft SQl Server 2005 - 9.00.3077 (X-64)

    Server 2 returned Microsoft SQl Server 2005 - 9.00.4035 (X-64)

  • You've definitely got different versions of the database instance patched, one to SP2 with a hot fix and the other to SP3. Have you tried failing over to the SP2 server and re-running the service pack install? If not, try that and post any error messages from the logs.

  • Which logs? I am fairly new and I know there are a log of logs. Just so I can narrow it down.

    Thanks for the patience. I will try to re-run the SP tonight.

  • Per your advice, I failed over the the SP2 server and I re-ran the SP3 install and it completed successfully. I tested all my apps and everything is working very well thank you so much for your help with this! :w00t:

Viewing 9 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic. Login to reply