Sp_monitor getting a 8115 msg

  • I'm running sql 7 sp3

    Is there a fix for this?

    last_run current_run seconds

    --------------------------- --------------------------- -----------

    2002-10-31 12:24:39.687 2002-10-31 12:29:31.077 292

    Server: Msg 8115, Level 16, State 2, Procedure sp_monitor, Line 94

    Arithmetic overflow error converting expression to data type int.

    packets_received packets_sent packet_errors

    ------------------------ ------------------------ ------------------------

    1517969(202) 799639(101) 1(0)

    total_read total_write total_errors connections

    ------------------- ------------------- ------------------- ------------------

    1073015(211) 4126404(550) 0(0) 1687865(626)

    John Zacharkan


    John Zacharkan

  • We are also getting this on our machine. The problem seems to be because out @@IDLE value is quite large. Of course our machine has been up for quite a while. If your machine has a high @@IDLE value then I would think if, you rebooted the box it might fix your problem. Of course you could also rewrite the sp_monitor sp to support large @@IDLE setting. Possibly that is why SQL 200) supports BIGINT values.

    Gregory Larsen, DBA

    If you looking for SQL Server Examples check out my website at http://www.geocities.com/sqlserverexamples

    Gregory A. Larsen, MVP

  • or just change this code:

    /*

    ** Set @mspertick. This is just used to make the numbers easier to handle

    ** and avoid overflow.

    */

    select @mspertick = convert(int, @@timeticks / 1000.0)

    to be: select @mspertick = convert(int, @@timeticks / 10000.0)

    John Zacharkan


    John Zacharkan

  • How /where can i obtain DDL for sp_Monitor?

    Likes to play CHESS

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply