Slow server after more memory added

  • ckempste

    SSCoach

    Points: 17983

    Hi all

    We have a prod server that has slowled significantly after more RAM was added, from 1gig to 2gig. We set the max SQLServer can use to 1900Mb. When it gets closer to the max queries slow significantly from around 1-2 sec up to 10secs. The DB is v7 SP2.

    Anyone had this problem before?

    Cheers

    CK


    Chris Kempster
    www.chriskempster.com
    Author of "SQL Server Backup, Recovery & Troubleshooting"
    Author of "SQL Server 2k for the Oracle DBA"

  • ckempste

    SSCoach

    Points: 17983

    More info:

    a) Server is running NT 4 SP5

    b) RAM installed is (not including base dimm)

    4x64Mb (banks 1&2)

    4x128Mb (banks 3&4)

    4x256Mb (banks 5&6)

    c) Tried to bump up swap files to 2gig from NT admin recommendations. No change experienced.


    Chris Kempster
    www.chriskempster.com
    Author of "SQL Server Backup, Recovery & Troubleshooting"
    Author of "SQL Server 2k for the Oracle DBA"

  • Andy Warren

    SSC Guru

    Points: 119676

    Been a while since I used SQL 7, but we did do a upgrade from 1 to 2g at one point and saw immediate improvment (lack of memory was generating excessive disk activity which then went away). Doubt the swap file would make a difference. Have you looked at the query plans for the slow ones? Statistics are current?

    Andy

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply