Site Settings and Security Tabs are missing from Reports Manager link

  • datsun

    SSCrazy

    Points: 2238

    To the SQL forum readers.

    From our SQL server 2005 Reporting Server page

    the tabs for Security and Site Settings are missing.

    I am logged in as Domain administrator on the server and also tried as a local domain user (myself), also an Administrator.

    I have unticked Anonymous access from Reports Virtual directory IIS setting and ticked it back to no avail.

    I have tried both http://localhost/reports and http://<servername>/reports and both have got the Security links missing.

    What could be wrong?

    I have attached the screenshot.

    BJ

  • peterzeke

    SSCrazy Eights

    Points: 8998

    I believe you need to be a local admin of the server that SSRS resides on. Anyone who is a member of the local admin group should be have default management of report manager.

    Another means to gain site wide admin access to report manager is to ask a colleague who has system admin rights in report manager to grant you system admin permissions as well (under site settings in report manager.)

    -- pete

  • datsun

    SSCrazy

    Points: 2238

    Hi Pete,

    Thanks for the reply.

    I am logged on as Domain Administrator on the server (highest possible credentials).

    Also tried logging on as local Administrator on ("this computer") server.

    In both logins I can't still see the security tabs on either http://localhost/reports or even http://<servername>/reports.

    My own username login is also "admin group" + DBA rights so I would think that itself should show up the security tabs.

    I am the only one who uses this server and created all the SSRS reports.

    I restarted the SSRS services but still no joy.

    I need the security tabs to restrict the view/content of some of the reports to some end-users on roll out.

    Anything else I could try to get it back?

    Thanks,

    BJ

  • djhurst

    SSC Journeyman

    Points: 91

    I've got this same issue. Anyone have any suggestions?

  • David Burrows

    SSC Guru

    Points: 64443

    Whether you are Domain Admin or Local Admin does not matter, it is role membership in SSRS that matters ie member of System Administrator role.

    BUILTIN\Administrators is added to the System Administrator role during setup so local admin should have access to site settings.

    It may be someone has removed or changed BUILTIN\Administrators role permission

    On the SSRS server try running browser as Administrator

    Or refer to http://stackoverflow.com/questions/707219/lost-ability-to-be-admin-on-sql-server-reporting-services-2005

    Far away is close at hand in the images of elsewhere.
    Anon.

  • luxiaotao

    SSC Enthusiast

    Points: 117

    I got same issue here. I tried following solutions, but no luck.

    1. logged as member of administrator

    2. logged as built-in administrator

    3. If I disable anonymous access and choose integrated Windows Authentication, it always prompt for user id and password, even I turn on 'Make automatic login user & password', but it didn't load regardless I key in any credentials.

    4. If I enable anonymous access and use member of administrator account, I can't see site setting nor any other toolbar to select.

    5. I run IE as administrator, got the same result.

  • David Burrows

    SSC Guru

    Points: 64443

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply